Cannot edit files in mount [Windows 10]

What is the problem you are having with rclone?

I'm trying to edit a nfo file inside my mount (from windows) and it doesn't let me, it keeps on saying that I don't have permission to do so. I can, however, move files around that are already present in the drive and I can rename and delete as well.

What is your rclone version (output from rclone version)

rclone v1.51.0

  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/arch: windows/amd64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

My mount command is :

mount --log-file "C:\rclone\log\rclonegdrive.log" --log-level INFO --allow-non-empty --allow-other --fuse-flag sync_read --tpslimit 10 --tpslimit-burst 10 --dir-cache-time=160h --buffer-size=64M --attr-timeout=1s --vfs-read-chunk-size=2M --vfs-read-chunk-size-limit=2G --vfs-cache-max-age=5m --vfs-cache-mode=writes --cache-dir "D:\cache\gdrive" --config "C:\rclone\rclone.conf" "Google Drive": M: 

I am using nssm to run the mount as a service.


Try running rclone as you rather than via nssm and see if it has the same problem.


  • please update to latest stable. v1.52.2
  • the latest stable of winfsp is v1.7
  • as per the docs, this does nothing on windows --allow-non-empty
  • tho not yet documented, this does nothing on windows --allow-other
  • to get around the permission problem, there are a few ways to that.
    the easiest is to run the rclone mount command as system user
    you can also use task scheduler.

Ah thanks that seemed to have fixed it.

I used nssm but ran the service as my user and that fixed it. I also removed the --allow-non-empty since you said it does nothing.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.