Cannot create WinFsp-FUSE file system: access denied

What is the problem you are having with rclone?

I am not able to mount my mega or google drive using rclone mount. I am running Windows 11.
I am getting the following error "Cannot create WinFsp-FUSE file system: access denied" on first run and "Cannot create WinFsp-FUSE file system: unspecified error." on the next consecutive runs until I restart my system.

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: Microsoft Windows 11 Home 22H2 (64 bit)
  • os/kernel: 10.0.22621.1105 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: cmount


Which cloud storage system are you using? (eg Google Drive)

Mega, Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount mega1: E:

The rclone config contents with secrets removed.

type = mega
user = redacted
pass = redacted
hard_delete = true

type = drive
client_id = redacted
client_secret = redacted
scope = drive
token = {"access_token":"redacted","token_type":"Bearer","refresh_token":"redacted","expiry":"2023-01-29T17:14:24.2648525+05:30"}
team_drive = 
use_trash = false

A log from the command with the -vv flag

2023/01/29 16:18:42 DEBUG : rclone: Version "v1.61.1" starting with parameters ["rclone" "mount" "mega1:" "E:" "-vv"]
2023/01/29 16:18:42 DEBUG : Creating backend with remote "mega1:"
2023/01/29 16:18:42 DEBUG : Using config file from "C:\\Users\\ypank\\AppData\\Roaming\\rclone\\rclone.conf"
2023/01/29 16:18:53 INFO  : mega root '': poll-interval is not supported by this remote
2023/01/29 16:18:53 NOTICE: mega root '': --vfs-cache-mode writes or full is recommended for this remote as it can't stream
2023/01/29 16:18:53 DEBUG : Network mode mounting is disabled
2023/01/29 16:18:53 DEBUG : Mounting on "E:" ("mega1")
2023/01/29 16:18:53 DEBUG : mega root '': Mounting with options: ["-o" "attr_timeout=1" "-o" "uid=-1" "-o" "gid=-1" "--FileSystemName=rclone" "-o" "volname=mega1"]
Cannot create WinFsp-FUSE file system: unspecified error.
2023/01/29 16:18:53 ERROR : mega root '': Mount failed
2023/01/29 16:18:53 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed

hello and welcome to the forum,

does a simple command work?
rclone lsd mega1: -vv

so you reboot, rclone works and then what?

have to tried to uninstall and reinstall winfsp?

make sure to use latest stable winfsp.

Hello, thanks for the reply.


rclone lsd mega1:

-1 2023-01-22 23:39:26        -1 Counter-strike  Global Offensive

rclone alone is working fine but I am not able to mount the volume, not able to create winfsp-fuse filesystem.

Reboot does not fix the issue, reboot only resets the error to Cannot create WinFsp-FUSE file system: access denied, after first run the error changes to "Cannot create WinFsp-FUSE file system: unspecified error."

Yes, reinstalled multiple times, also using the latest version of winfsp.

have you search the forum, as this is has been occurring more often recently.

hmmm, not sure what is going on.

just some simple things i would try:
--- run the command prompt with admin privileges.
--- try installing an older version of winfsp,
i ran this version of years - Release WinFsp 2019.3 · winfsp/winfsp · GitHub
--- add --vfs-cache-mode=full
--- i always mount to a path, never a drive letter.
rclone mount mega1: b:\rclone\mount\mega1
change b:\rclone\mount\mega1 to match your system, perhaps c:\mega1

Thanks!! The issue is resolved. For those who are facing this issue:

  1. Running cmd as admin did not help, not reinstalling winfsp or rclone.
  2. The problem got solved using a lower winfsp version ( for me, latest was 1.12, I downgraded to 1.11 and it worked )

Winfsp also can't be the problem, i posted problem like that earlier but in my post the cause of problem was: cyrillic symbols displaying as question marks in config in CMD
It was in log here and of course it contained question marks instead of cyrillic symbols so rclone coulnd't mount my remote because of encoding
Verison of Windows isn't the problem because i also had this problem a month ago on Windows 2012 R2 VPS

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.