Cannot create pCloud config file on OSX

What is the problem you are having with rclone?

Cannot complete config process from command line for pCloud on OSX Catalina.

(1) Followed the example on the rclone pCloud config page.

(2) It opens up the web browser to get authorisation from pCloud. We are able to log into our pCLoud account:
https://my.pcloud.com/oauth2/authorize?access_type=offline&client_id=

(3) The page then crashes and the error URL says:
https://undefined/oauth2/authorize?client_id=

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: darwin/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

OSX 64-bit Catalina

Which cloud storage system are you using? (eg Google Drive)

pCloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

The rclone config contents with secrets removed.

No config file yet - as process will not complete.

A log from the command with the -vv flag

no log

The login with pcloud seems a bit odd...

Can you try rclone 1.49.5 and see if that works for you? If it does then the config should work fine for 1.51.0 also.

Hello and thanks for taking time to respond. Unfortunately, the older version had the same result (same error).

Everything else with pCloud is fine. We are able to rsync to the drive mount - but it is painfully slow.

Have attached a screenshot so you can see exactly the error. It may also help to know that we use two-factor authentication. This error happens after that second authentication has been approved.

Hmm, that looks like it is a bug with pcloud. You can see the redirect url "http://localhost:53682/" where it should be going but for some reason it doesn't get there...

Can you ask pcloud support about this?

Hello and thank you again. We looked into it and see that others are having the same issue. It appears to happen with those using two-factor-authentication. Others are stating it's a new issue. We tried the solutions in https://github.com/rclone/rclone/issues/4210#issuecomment-629680511 but it had the same result.

Even if we are logged in via the web, and attached to the pCloud Drive - we get the same error.
Here are some links that may help:

https://github.com/rclone/rclone/issues/4210
https://github.com/rclone/rclone/issues/4210#issuecomment-629680511

https://docs.pcloud.com/protocols/http_json_protocol/
https://docs.pcloud.com/protocols/http_json_protocol/authentication.html
https://docs.pcloud.com/methods/intro/authentication.html
https://docs.pcloud.com/methods/oauth_2.0/
https://docs.pcloud.com/methods/oauth_2.0/authorize.html
https://docs.pcloud.com/methods/oauth_2.0/oauth2_token.html

Can you all have a go with this which attempts to work-around the problem?

https://beta.rclone.org/branch/v1.51.0-369-g4599e484-fix-4210-pcloud-oauth-beta/ (uploaded in 15-30 mins)

Thank you very much for the effort. Unfortunately we got that same result.

betatestresult

Note: We ran a test earlier while quickly disabling the two-factor authentication. The goal was to isolate further what is causing the issue. Without 2FA, we got farther through the rclone config process, but ended up on screen like mentioned in other posts:

Error: Auth state doesn't match
Description: Expecting " .secret stuff here" got ""

Thanks again for the effort. It is appreciated.

OK

The new build should fix that particular problem - can you give that a go?

Hello - we did try the new build. It got us through the 2FA but then we received the same "Can't find server" message above.

We used the download link sent - the Mac OSX 64-bit version.

We also have rclone installed from Homebrew, but we made sure that the rclone config command was using the beta version.

I was hoping you'd try it without 2FA and see if that works...

Hello and thanks - we dropped 2FA long enough to get the config file process completed. It worked. We then ran a quick sync to validate - it worked. Turned 2FA back on and all is working as expected.

1 Like

Great thanks. We need to work on getting in working with 2FA but we at least have a workaround now!

Really appreciate the support and am happy to make a donation!

1 Like

The "Two-Factor Authentication" is disabled. and still doesn't works.
I did a try with the latest stable version AND the beta no luck.

rclone v1.52.0-003-g764b90a5-beta

  • os/arch: darwin/amd64
  • go version: go1.14.3

Notes that may help:

  1. We used rclone-v1.51.0-369-g4599e484-fix-4210-pcloud-oauth-beta-osx-amd64.zip .

  2. Upzipped it and moved it into /usr/local/bin as the instructions (readme) say. It overwrote the copy of rclone installed by Homebrew (brew uninstall rclone may be needed).

  3. Disabled 2FA on pCloud using the web interface and then rebooted the Mac.

  4. Logged out of pCloud Drive.

  5. Ran: /usr/local/bin/rclone config from the command line. Followed the prompts and after it said "success" on the screen, went back to the command shell to complete the config process.

After it completed, we have been able to use the beta reliably. Hope it helps!