Cannot connect to pcloud

What is the problem you are having with rclone?

Cannot connect to pcloud as storage backend

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

Which cloud storage system are you using? (eg Google Drive)

Pcloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

Add pcloud (storage option 26)

A log from the command with the -vv flag

Opens web browser - after entering email/password I get this error

If your browser doesn't open automatically go to the following link: http://127.0.0.1:53682/auth?state=VuGC_kJK5yR8-SEa7gyuTw
Log in and authorize rclone for access
Waiting for code...
2020/05/23 11:56:52 Failed to configure token: Error: Auth state doesn't match
Code: ""
Description: Expecting "VuGC_kJK5yR8-SEa7gyuTw" got ""
Help:

Good Morning.

Same problem here. Was getting me mad, thinking was my fault.
Tried w10+ firefox
w10+ chrome
kubuntu 20.04 +firefox
with no success and same error

As a temporary workaround you can use webDAV - it seems much slower but still works.

Something I noticed - this approach treats the backend as case sensitive and confuses the pcloud windows application mightly so be careful to use same case as existing folders

I'm in test phase to choose a cloud for backup some "heavy" files, so the slow one wil not be the winner. I'll expect some fix for this issue or I'll choose another one cloud service.

It's a pyty because the "for life" service from pcloud is very interesting.

Try temporarily using rclone 1.49.5 to make a token while I work on a fix! The config as generated will work fine with rclone 1.51.0 and later.

It looks like pcloud have lost the state parameter when doing the redirects so technically this is a pcloud bug.

1 Like

Thanks Nick. The work-around worked :rofl:

Thank you very much. Worked for me too.

Great! I think this is a bug at pcloud - does anyone fancy contacting their support? The bug is the state parameter went missing during the oauth transaction.

I'll do a work-around in the mean time.

Hi guys.
I use Ubuntu.

My email to pCloud 3 days ago:

Hi Guys,
I am trying ton connect pCloud via RCLONE (Linux) but each time I try to setup the remote I get a message in a red box from pCloud website saying " This 'redirect_uri' is not authorized."
Could you please explain me how I could setup RCLONE to use pCloud?
Thanks a lot

pCloud's answer yesterday:

Hello,
Thank you for your e-mail.
Unfortunately, we cannot assist on the matter, as we do not support rclone anyhow.
We have recently changed our public and download links' sub-domain, which might be causing the error. Please contact rclone's support for help.
Please ask if you have any questions!

Best,
Paul J. Klee
pCloud's Technical Support

Their oauth is broken... I'll try writing a. more technical email to them explaining exactly how.

I'll also make a workaround which isn't too hard.

Better put in your workaround a "please complain to pcloud" as otherwise the pcloud tech guys would get lazy and not actually fix their end....

Can you all have a go with this which attempts to work-around the problem?

https://beta.rclone.org/branch/v1.51.0-369-g4599e484-fix-4210-pcloud-oauth-beta/ (uploaded in 15-30 mins)

It worked!

(tested on windows 32-bit; not sure why but there isn't a 64-bit version in the link)

Thanks for testing.

I've merged this to master now which means it will be in the latest beta in 15-30 mins and released in v1.52

The amd64 build was missing due to a CI machine hiccough.