Cached box remote - how do I make all the files end up on remote?

I have a configured box remote. On top of it I have a cache remote

[box]
type = box
client_id =
client_secret =
token = 
commit_retries = 500

[box_cached]
type = cache
remote = box:
chunk_size = 64k
chunk_total_size = 1G
tmp_upload_path = /tmp/box-cache

I rclone sync-ed one directory to the cached remote. But not all the files have been transferred to the underlying box remote. The rclone sync has finished, but plenty of files are still in the cache.

How do I actually make them end up on the original, underlying box remote?

By default, it uploads them after 15 seconds:

https://rclone.org/cache/#cache-tmp-wait-time

It uploads them one by one.

Not sure why you'd rclone sync locally rather than sync directly to the "box:" remote.

Thanks for the answer.

What I am trying to do is use cryfs on top of either box, cached box (also mounted, both variants) or box via davfs. I would like to see, what is the fastest.
So far rclone mount is totally unreliable and slow (I tried caching remote, vfs-cache in various combinations, but the differences are insignificant - but then again - maybe I am doing something wrong), so I am trying to use sync. I assumed caching the target would speed-up the process - it was the purpose of it, right?

I tried sync-ing it again - the process has finished, there is no rclone process in the background, and only 10% of files are on target remote. I can't see any network activity related to the box either.

How is it supposed to upload them?
I'm probably doing something wrong - how should I call rsync clone for the cached files to reach the target remote?

I'd guess your problem with cryfs playing with rclone as if you check their github, they are issues with it. The way cryfs works isn't generally going to play well with rclone as I tested it out myself although I am use Google Drive.

The purpose of the cache remote is to cache files used a lot locally. It does provide an offline uploading feature that you are using but you haven't provided:

  • what version you are using
  • what mount command you are using
  • any logs to help troubleshoot the issue
  • what sync command you run and any logs associated with it

Saying it's unreliable or doesn't work without providing any information won't help solve the issue.