Cache ls throwing errors and crashing

I’m am trying out the new cache feature for the first time. I set up the cache remote directly on top of my Google Drive remote (not on the decrypted remote) and tried to do list the files. The first time I try the command, I get this:
2018/01/11 18:05:20 ERROR : vn15h4p6371nmpmjdlj3od94: error listing: directory not found
2018/01/11 18:05:20 Failed to ls: directory not found

Then, if I run the command a second time, I get a panic:
panic: runtime error: slice bounds out of range

goroutine 15 [running]:*Directory).Remote(0xc420132000, 0x4, 0x4)
/home/travis/gopath/src/ +0x117*Persistent).GetDirEntries.func1(0xc4203d8000, 0xff3818, 0xc4203d8000)
/home/travis/gopath/src/ +0x2d5*DB).View(0xc4203143c0, 0xc4204a4ae0, 0x0, 0x0)
/home/travis/gopath/src/ +0x9a*Persistent).GetDirEntries(0xc42046c870, 0xc420132000, 0x0, 0xc420132000, 0xc4204a4b68, 0x411b2c, 0xc4204a4b68)
/home/travis/gopath/src/ +0x7d*Fs).List(0xc42025d040, 0x0, 0x0, 0x0, 0xc420020600, 0x0, 0x0, 0x0)
/home/travis/gopath/src/ +0xb3, 0xc42025d040, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
/home/travis/gopath/src/ +0x63, 0xc4201cb440, 0xff3400, 0x1595a20, 0xc42025d040, 0xc420444f00, 0xc4203e2070, 0xc420073650, 0xc4203e2050, 0xc4201a82d0, …)
/home/travis/gopath/src/ +0x1e3
created by
/home/travis/gopath/src/ +0x265

I am using the latest beta: rclone-v1.39-023

I also tried it with v1.39 release.

Thanks for the help.

This is likely the same issue as (at least the traceback looks the same). Can you add your info to that issue please?