Cache - ERROR : : list: save error: 'bucket name required'


#1

Hi,
Properly my configuration but I get an error when trying to mount a encrypted mount point or a cache mount point on OSX Sierra. Any help greatly appreciated.

Error ERROR : : list: save error: ‘bucket name required’

Gdrive has folder media

Drive config
GDrive -> Cache -> encrypted

/usr/local/bin/rclone mount gcache: /Users/xbmc/media
–allow-other
–dir-cache-time=1m
–cache-tmp-upload-path=/Users/xbmc/.cache/rclone/cache-upload
–cache-chunk-size=32M
–cache-info-age=168h
–cache-tmp-wait-time=10m
–cache-workers=5
–buffer-size=16M
–attr-timeout=1s
–rc
-v 3

[gdrive]
type = drive
client_id = removed
client_secret = removed
scope = drive
root_folder_id =
service_account_file =

[gmedia]
type = crypt
remote = gcache:
filename_encryption = standard
directory_name_encryption = true
password = removed
password2 = removed

[gcache]
type = cache
remote = gdrive:media
plex_url =
plex_username =
plex_password =


#2

That confusingly is an error from boltdb which is used by cache.

Not sure exactly what is happening, but I suspect running cache once with --cache-db-purge will purge the cache database and it will work…


#3

Hi,
I tried --cache-db-purge and deleting the cache db but still get the same error. Any ideas?


#4

Sorry ignore my last post as I have now got the cache working.

Thanks for your help.

Phil


#5

Hi,
I have rclone working with cache -> encrypt but the following error occurs intermittently;

2018/06/09 22:06:49 ERROR : : list: save error: ‘bucket name required’
2018/06/09 22:11:25 ERROR : : list: save error: ‘bucket name required’


#6

I don’t know what could be causing that error. @remus.bunduc any ideas?


#7

It seems caching of the root folder got bugged when trying to fix a performance issue. I don’t think there was any major impact to it but at any rate: https://beta.rclone.org/v1.41-101-gf9a1a7e7/ here’s the beta with the fix.


#8

Hi,
I have updated to the latest beta the error has been fixed.

Thanks for your help.

Phil