Cache directory tree on mount on OS X

What is the problem you are having with rclone?

rclone is working great but id like to cache/load the directory tree on mount, initial scan can be slow on Plex or emby but once its in cache its really fast. hope ive explained this right, I think similar to here but im not on windows so don't understand this post How to get full directory tree cached on first mount? thanks Bryan

What is your rclone version (output from rclone version)

rclone v1.50.2-123-gae340cf7-beta

  • os/arch: darwin/amd64

  • go version: go1.13.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Mac OS Catalina 15.2 64 bit

Which cloud storage system are you using? (eg Google Drive)

Gooogle Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

my mount command is rclone mount gdrive: ~/gdrive --allow-non-empty --timeout 1h --tpslimit 10 --dir-cache-time 99999h --vfs-cache-mode writes --vfs-cache-max-age 1h --poll-interval 1m --vfs-read-chunk-size-limit 1024M --vfs-read-chunk-size 26M --buffer-size 16M

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

You need to traverse the whole tree on startup. You can use:

rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5572

If you run rclone rc and that will refresh the entire tree pretty fast. That's what I do on mount.

This is bad as it allows over mounting. I'd remove this.

Any reason for these? I'd remove and use the defaults.

thanks for your reply really appreciate it,

so answering your questions backward

Any reason for these? I'd remove and use the defaults.

--vfs-read-chunk-size-limit 1024M --vfs-read-chunk-size 26M --buffer-size 16M

I have used a guide somewhere on internet for a mount for Plex so really just followed it so I will remove and try

This is bad as it allows over mounting. I'd remove this.

--allow-non-empty

ill remove this as well and try

You need to traverse the whole tree on startup. You can use:

rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5572

so do I type my mount command and then run this after the mount has shown ?

so I use terminal on osx and ill mount drive

rclone mount gdrive: ~/gdrive --timeout 1h --tpslimit 10 --dir-cache-time 99999h --vfs-cache-mode writes --vfs-cache-max-age 1h --poll-interval 1m

then run command

rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5572

thanks
Bryan

so ran

rclone mount gdrive: ~/gdrive --timeout 1h --tpslimit 10 --dir-cache-time 99999h --vfs-cache-mode writes --vfs-cache-max-age 1h --poll-interval 1m

all mounted no problems

then ran

rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5572

and got following

2020/01/12 19:10:53 Failed to rc: connection failed: Post http://127.0.0.1:5572/vfs/refresh: dial tcp 127.0.0.1:5572: connect: connection refused

any help appreciated
thanks
Bryan

You need to use the remote control option in your mount as it'll spawn the remote control process.

Just add:

--rc

to your mount and you are good to go.

You can see more info here:

https://rclone.org/rc/

thanks ill go experiment

Bryan

brilliant that worked thanks for sorting this for me

much appreciated
Bryan

hi
sorry one last question can I just refresh 1 directory, using this command to refresh the whole drive

rclone rc vfs/refresh recursive=true --rc-addr 127.0.0.1:5572

thanks
Bryan

That command does the whole thing.

Check here for the syntax for a directory:

https://rclone.org/rc/#vfs/refresh

thank you once again

Bryan