--bwlimit switching at the wrong time

So I am trying to setup an upload with the command

rclone copy /media/data/plex/.local/G8CBuhkR6rowY6LvaWa99g== acd:crypt/G8CBuhkR6rowY6LvaWa99g== --bwlimit "08:00,50 01:00,off" --etc

From my understanding this should allow the upload to go at full speed between 01:00 and 08:00 and limit it to 50kB/s for the rest of the time. But for some reason it already switches to full speed at midnight. It even says in the logfile:

2017/04/21 00:00:20 NOTICE: Scheduled bandwidth change. Bandwidth limits disabled

Can someone tell me why this might be? I first thought it might be rclone using UTC but I am 2 hours ahead of UTC, so it does not match.

The bwlimit specifies a 24 hour schedule so --bwlimit "08:00,50 01:00,off" the 01:00,off wraps around to midnight.

Try --bwlimit "01:00,off 08:00,50 " - that should do what you want hopefully, with the 50 wrapping round to midnight.

1 Like