Bug with --drive-shared-with-me flag

The ls command does not work when using root dir. It actually shows the main files instead of the shared files. Eg:

rclone ls gdriveP: --drive-shared-with-me --fast-list -v

But it works fine, if I specify a dir. Eg:

rclone ls gdriveP:jordan --drive-shared-with-me --fast-list -v

The same issue when using copy command.

  1. too soon to call this a bug. you should re-post this as a question and provide the requested information.
  2. try running the same command but with -vv instead of -v. to see the debug logging info.
  3. try to save the logging info to a log file using flag –log-file.
  4. try same command but without --fast-list

when using root

2019/10/17 22:19:26 DEBUG : rclone: Version "v1.49.5" starting with parameters ["rclone" "ls" "gdriveP:" "--drive-shared-with-me" "-vv" "--log-file" "foo.log"]
2019/10/17 22:19:26 DEBUG : Using config file from "C:\\Users\\HARRY\\.config\\rclone\\rclone.conf"
2019/10/17 22:19:30 DEBUG : 9 go routines active
2019/10/17 22:19:30 DEBUG : rclone: Version "v1.49.5" finishing with parameters ["rclone" "ls" "gdriveP:" "--drive-shared-with-me" "-vv" "--log-file" "foo.log"]

when using dir

2019/10/17 22:24:46 DEBUG : rclone: Version "v1.49.5" starting with parameters ["rclone" "ls" "gdriveP:jordan" "--drive-shared-with-me" "--fast-list" "-vv" "--log-file" "foo.log"]
2019/10/17 22:24:46 DEBUG : Using config file from "C:\\Users\\HARRY\\.config\\rclone\\rclone.conf"
2019/10/17 22:24:49 DEBUG : 15 go routines active
2019/10/17 22:24:49 DEBUG : rclone: Version "v1.49.5" finishing with parameters ["rclone" "ls" "gdriveP:jordan" "--drive-shared-with-me" "--fast-list" "-vv" "--log-file" "foo.log"]

@thestigma @Animosity022 are you aware of such issue?

@Harry I managed to replicate this...

Can you please make a new issue on github about this and we can try to fix - thanks! Put a link to the forum thread in the issue please.

--drive-shared-with-me seems to be broken... None of the files printed are shared...

cw@dogger:~$ rclone lsf -R TestDrive: --drive-shared-with-me=false --files-only | grep -v /
make_test_files.exe
README.md
z2.txt
z3.txt
make_test_files.exe
debian-8.6.0-amd64-netinst.iso
hello.txt
This is a Sheets.xlsx
^C
ncw@dogger:~$ rclone lsf -R TestDrive: --drive-shared-with-me=false --files-only | grep -v /
make_test_files.exe
README.md
z2.txt
z3.txt
make_test_files.exe
debian-8.6.0-amd64-netinst.iso
hello.txt
This is a Sheets.xlsx
^C
ncw@dogger:~$ rclone lsf TestDrive: --drive-shared-with-me --files-only
ncw@dogger:~$ rclone lsf --disable ListR -R TestDrive: --drive-shared-with-me --files-only

This might be related to this issue

I have also added a interesting things, that you will find weird..!

https://github.com/rclone/rclone/issues/3639

I'm afraid I have very little personal experience with that particular flag due to my setup. Sorry! :confused: