Bug in saving random generated password in config crypt

What is the problem you are having with rclone?

In 'rclone config' on crypt remote, random generated password is not saved correctly. In rclone.conf, only first 16 byte(iv for obscure password) is saved so password treated null.

What is your rclone version (output from rclone version)

rclone v1.49.0

  • os/arch: linux/amd64
  • go version: go1.12.9

(in rclone v1.48.0, correctly works)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux, 64 bit

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

I'll reply on the github issue: https://github.com/rclone/rclone/issues/3492

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.