Buffer-size not actually used (disproved)

Does anyone notice any difference when enabling the buffer-size? I’ve tried it and I do see it download more data but from the client side, I see zero effect. Its almost like the client isn’t pulling from the buffer at all. I see the same EXACT symptoms with a 0M, 50M, and a 1G buffer. If the buffer was working and I set it to 1G (the size of the file) I shouldn’t see any buffering on the client stream. My hunch is that the client is not being served from the buffer when streaming.

What system are you using and what cloud providers are you referring to?

Linux and Amazon and Google drive.

These are all mounts, however…

How are you testing this?

Well. I was able to disprove my theory my using a few tools and network qos to simulate things a bit. It is in fact working correctly.

I have been playing around with --buffer-size for the last couple of hours and it seems to me that whatever buffer size I select - tried 128M, 150M, 64M - rclone is always using the default buffer size.

My files are just some trailers and one of them I tested is just about 90mb so a buffer size of 128 or 150M should have buffered it completely but it didn’t. It buffered a bit and then continued buffering as the playback progressed.

I’m using rclone 1.38 and ACD.

Would be glad about any hint you guys may have.

Does nobody have an idea why it does not work as it should?

If your internet speed is lower than the play speed of the video then you’l get buffering.

Try starting the video and then pausing it. You should see rclone memory usage goes up as it buffers then plateau as the buffer is full. That should tell you whether buffering is working.

My internet speed is way faster than the bitrate of the file, so that shouldn’t be the problem.

Will try that with different settings and report back. Thanks a lot!