Box Token Error?

#1

I have been using rclone to sync to box for over a year. I created the access token using the remote setup in the docs. I authorized box and pasted the token to the remote according to the docs. The sync is automated running in a cron job nightly. All has been working great for the past year. I noticed yesterday, sync failed and the log showed a strange certificate error.

2019/05/14 00:07:06 ERROR : : error reading destination directory: couldn't list files: /token: x509: certificate is valid for mydomain.com, not app.box.com

I thought easy fix. My token must have expired so I deleted the remote and created a new one using remote headless server method. I authorize box, get the new token, paste it in, etc. I run sync and it works again. I thought great. That was easy.

However, got the same error the next day. Then a closer examination of the token shows it expires same day. Did something change on Box's end? It seems the token that is created using:
rclone authorize "box" is returning a token that expires shortly after it's creation.

Here's a partial paste of the token created on 5/14/19
"expiry":"2019-05-14T10:51:40.4456521-07:00"

As my backup and sync is automated with a script that runs in cron nightly, the sync will continue to fail. It seems unreasonable to expect one to have to create a new token manually each day for an automated script to work.

Is there a solution for this?

Thank you!

#2

The expiry date of the token is normal, rclone will refresh it automatically when it expires.

However that SSL certificate error is not normal. Either box has messed up their certificates or you've got something between you and box (a proxy maybe) which is interfering.

#3

You are correct. I use the Pihole DNS ad blocker on my network. Recently I added many more domains to the block list. Unbeknownst to me, I inadvertently blocked the box domain. I whitelisted "app.box.com" and works perfect now.

Thank you so much!

1 Like