Box fail to copy file_size_limit_exceeded

What is the problem you are having with rclone?

Running into 'file_size_limit_exceeded' error

What is your rclone version (output from rclone version)

rclone v1.53.3

  • os/arch: windows/amd64
  • go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10, 64 bit

Which cloud storage system are you using? (eg Google Drive)

Box (free account, testing before buying)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount boxTest:rcloneNonCrypt x: --vfs-cache-mode writes --box-upload-cutoff 100M --log-file=LOGFILE.txt

The rclone config contents with secrets removed.

It's an encrypted config. Nothing has been changed since running the default box config.

A log from the command with the -vv flag

gist [dot] github [dot] com/Adoah/44ceca577be16f36fa2659b1fff6544a

I suppose I should say that I expected rclone to switch to a multi-part upload based on the default 50M size parameter. I ran it without the " --box-upload-cutoff" flag and with it and got the same behavior.

Those are normal errors as the free box account has limits:

I'm aware of this limit, however, I was under the impression that rclone would automatically switch to a multipart upload where it would split the file into 50MB parts, thus making the maximum file size a non-issue. Am I mistaken in the definition of a multipart upload, or does rclone not have this ability at all?

If you have a 1GB file and you use multi part upload, it uploads in say 250MB segments. It doesn't have anything to with changing the file size.

It's explained a bit here:

Got it. So it splits the file and uploads multiple parts simultaneously, however it doesn't have any effect on the "output" file size in box, i.e. box will still only see 1 file. Correct?

Yes, that's right. So if you want to upload big files, you need to be a better plan.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.