Best mount settings for streaming ( Plex )


#649

So far is hasn’t crashed since yesterday morning and it still continues to perform well. So while it aint broke i’m not going to touch it :slight_smile:


#650

Is here anyone who has encrypted data on google drive and is able to jump to a specific time in a tv series or movie? Yesterday a stream stopped unexpectedly 7 minutes before the end. I was not able to jump to the specific time neither could I fast-forward. Is this not possible or can I tweak this somehow? Using plexmediaserver on a raspberry pi 3 with only rclone to mount read only.


#651

You can build it from the source and it’s easy.

Make sure install Go Language on your computer and then this :

go get github.com/dweidenfeld/plexdrive && go build github.com/dweidenfeld/plexdrive

If it’s your first time, it will give you bunch of error that package “X” is not there and you can get them by

go get X


#652

update- i tried removing all the folders/files and doing plexdrive again with the same parameters you all are using… after the long cache build,. it was just as flaky as it was the first two times i tried…

so i thought i’d give google-drive-ocamlfuse a shot… (i guess i need to use a verbose parameter or something because i get no feedback/info on what its doing) the only way i could tell it was doing something… was when i updated a library… 100mbs was being received for like 30 minutes?!
i guess that was building the cache for that folder??

anyways i’ve managed to update my entire 30tb library via ocamlfuse… with no ban.

the amazing thing is how much better gdrive streams than acdcli/acd did…

i keep a couple ultra high bitrate like 40gb files on the cloud to test with (and acd always choked eventually) but gdrive ocamlfuse plays them flawlessly/instantly…

amazon did me a favor by wimping out :slight_smile:


#653

although watching ocaml now… it does seem to be using 100s of gbs for cache!?

not sure why when i update a library it needs to download 100mbs a sec for like 30 min??

is there a parameter to limit how much it caches or something??


#654

ocaml, doesn’t use local cache and it do cache in memory, you can change the setting in the config file, check it in the wiki section of the ocamlfuse GitHub.


#655

Turn:

stream_large_files=false to true.

Specifies the threshold (in megabytes) to detect large files:

large_file_threshold_mb=16


#656

yes i finally figured out that the 100s of mbs were happening when i started playing a large file (and during that period 20 minutes or so lay : ) : (

i’ll look at the wiki…

a little confused by what those parameters mean animosity…

if i set that to true… it will stop downloading/caching those 100s of mbs on start of play?

and the threshold means it will stream everything larger than 16mb?

thanks…


#657

Yep. that’s right. ocaml uses memory to stream large files and which is different from plexdrive that downloads temporary chunks and doesn’t use memory at all.

The 16MB is the default setting I believe that it considers every file over that setting to be a ‘large file’ and it’ll stream it.


#658

Thanks…
it fixed the problem ; )

btw… would it help things at all if i increased the memory cache size? i can probably spare 10 gigabytes…


#659

you need at least go 1.7 to build. works without any effort. thank you @Danial_Hanafian. :slight_smile:


#660

I too had to give up on Plexdrive. When it worked it worked great but it the last few days it’s just been crashing constantly. Downgraded versions, deleted the cache and it just seemed to get worse with every step I took. Hopefully a more stable version comes out soon but for now it’s back to ocaml :frowning:


#661

I seem to also have a problem with plex drive. It keeps downloading chunks even tho no one is playing anything untill my server is full and unresponsive.

I’m running:
plexdrive --clear-chunk-max-size=20G --chunk-size=30M -o allow_other -v 3

Any help would be appreciated :slight_smile:


#662

Mine was doing the same but without --clear-chunk-max-size=20G --chunk-size=30M as options. A reboot has freed up the space.


#663

What library settings are you running? Plexdrive doesn’t download anything on its own.


#664

Can anyone comment on how well the latest plexdrive is working? Is it worth the hassle to setup?

Also, does anyone have any experience with the other platforms like Kodi, Emby as alternatives?


#665

#666

With Sonarr downloading proper version of already added stuff, I had the .unionfs-fuse folder on my local drive which somehow “got” into plexdrive

As I can see such errors:

PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE
[PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE
[PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE

where “,6JJ76zdHfvysUMBCAKtZBYk” is the crypted folder name of .unionfs-fuse
BUT I cannot see it anywhere on GDRIVE
nor local…
is it somehow cached? How can I remove this from my plexdrive cache?
Do I have to remove it?

:smiley:

xxx# ~/plextmp/chunks $ cd 0B0fKJMA00CwzdFowcjZpSUt3VVE
-bash: cd: 0B0fKJMA00CwzdFowcjZpSUt3VVE: No such file or directory

the chunk folder is now even “local”


#667

I liked it but started to crash more and more. The day I gave up on it Plexdrive had crashed 4 times in a matter of hours. My library scans every 15 mins (20TB) and when the mount dropped Plex would start to remove the content so it was a vicious cycle of scanning it all back in again.

This was after downgrading the version, deleting the cache multiple times. I do hope future versions become more stable as the streaming was almost instant. I’m using google ocaml now and has crashed once in the past 3 days. Plexdrive was at least once every 24 hours.

*edit - I scan the library every 15 mins as even having Sonarr and Radarr tell Plex it won’t show the content up until a manual scan is done


#668

Plex would start to remove the content so it was a vicious cycle of scanning it all back in again.

In plex, disable ‘Empty trash automatically after every scan’.