Best mount settings for streaming ( Plex )

I too had to give up on Plexdrive. When it worked it worked great but it the last few days it’s just been crashing constantly. Downgraded versions, deleted the cache and it just seemed to get worse with every step I took. Hopefully a more stable version comes out soon but for now it’s back to ocaml :frowning:

I seem to also have a problem with plex drive. It keeps downloading chunks even tho no one is playing anything untill my server is full and unresponsive.

I’m running:
plexdrive --clear-chunk-max-size=20G --chunk-size=30M -o allow_other -v 3

Any help would be appreciated :slight_smile:

Mine was doing the same but without --clear-chunk-max-size=20G --chunk-size=30M as options. A reboot has freed up the space.

What library settings are you running? Plexdrive doesn’t download anything on its own.

Can anyone comment on how well the latest plexdrive is working? Is it worth the hassle to setup?

Also, does anyone have any experience with the other platforms like Kodi, Emby as alternatives?

With Sonarr downloading proper version of already added stuff, I had the .unionfs-fuse folder on my local drive which somehow “got” into plexdrive

As I can see such errors:

PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE
[PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE
[PLEXDRIVE] [2017-06-07 23:02] DEBUG : Could not find object with name ,6JJ76zdHfvysUMBCAKtZBYk in parent 0B0fKJMA00CwzdFowcjZpSUt3VVE

where “,6JJ76zdHfvysUMBCAKtZBYk” is the crypted folder name of .unionfs-fuse
BUT I cannot see it anywhere on GDRIVE
nor local…
is it somehow cached? How can I remove this from my plexdrive cache?
Do I have to remove it?


xxx# ~/plextmp/chunks $ cd 0B0fKJMA00CwzdFowcjZpSUt3VVE
-bash: cd: 0B0fKJMA00CwzdFowcjZpSUt3VVE: No such file or directory

the chunk folder is now even “local”

I liked it but started to crash more and more. The day I gave up on it Plexdrive had crashed 4 times in a matter of hours. My library scans every 15 mins (20TB) and when the mount dropped Plex would start to remove the content so it was a vicious cycle of scanning it all back in again.

This was after downgrading the version, deleting the cache multiple times. I do hope future versions become more stable as the streaming was almost instant. I’m using google ocaml now and has crashed once in the past 3 days. Plexdrive was at least once every 24 hours.

*edit - I scan the library every 15 mins as even having Sonarr and Radarr tell Plex it won’t show the content up until a manual scan is done

Plex would start to remove the content so it was a vicious cycle of scanning it all back in again.

In plex, disable ‘Empty trash automatically after every scan’.

1 Like

with plexdrive I have in every 2-3 days a crash, like this:

[PLEXDRIVE] [2017-06-10 02:22] DEBUG : Deleting oldest chunk file /home/plex/plextmp/chunks/0B0fKJMA00CwzNlpwY2xwVlo4Szg/178257920
[PLEXDRIVE] [2017-06-10 02:22] DEBUG : Requesting object 0B0fKJMA00CwzT3pqVGo4dEE4dkk bytes 1268776960 - 1274019840 from API
[PLEXDRIVE] [2017-06-10 02:22] DEBUG : Requesting object 0B0fKJMA00CwzT3pqVGo4dEE4dkk bytes 1274019840 - 1279262720 from API
[PLEXDRIVE] [2017-06-10 02:22] DEBUG : Cleaning empty directory /home/plex/plextmp/chunks/0B0fKJMA00CwzR0EyR1I3V0I3RFk
panic: runtime error: invalid memory address or nil pointer dereference

this is how I’m starting it:

plexdrive -v 3 -o allow_other,read_only -t /home/plex/plextmp/ --clear-chunk-max-size=100G /home/plex/ACD/.gdrive

Don’t know if my box is in need of a re-install but Google OCAML was crashing once a day as well. I’ve switched back to the new version of PlexDrive 4.0.0. It’s been running for 24 hours without issue so far.

There is an issue I have open where it’s not showing all my content so am just waiting to hear back if I need to rebuild the database or something.

Hi guys

What the best (and ban/stuttering free, of course) mount settings if i use Plexdrive and rclone (rclone only encrypt)?

Now i use this:


/usr/bin/plexdrive -v 2 /mnt/plexdrive (no switches)


/usr/bin/rclone mount --read-only --allow-other --acd-templink-threshold 0 --stats 1s --buffer-size 1G --timeout 5s --contimeout 5s --max-read-ahead 1G -vv --log-file=/home/vamp/log/rclone_log Plexdrive_crypt:/ /home/vamp/google

in my case I substituted the RCLONE MOUNT with PLEXDRIVE.
As my DATA was encFS encrypted.
So, if you don’t relay on crypt from rclone, you could just forget the rclone mount
And copy your data to the cloud with rclone COPY/MOVE frequently.

All the mount part will be done by plexdrive.

(Plexdrive 4.0 needs mongodb and “-m localhost” switch as well)

I use 4.0 and installed Mongodb, but my systemd script just this(not -m localhost switch):

# /etc/systemd/system/plexdrive.service


ExecStart=/usr/bin/plexdrive -v 2 /mnt/plexdrive
ExecStop=/bin/fusermount -u /mnt/plexdrive


It need to this use mongodb?

(the mount work well)

The Rclone mount need, because i dont want to re-encrypt everything.

And it need to use some switches on plexdrive or need to delete some with rclone?

i have a problem with buffering the start from movies is very fast 1-3 seconds but after a few minutes beginns the buffering. Play- Buffering 1-20seconds - Play - Buffering - …

i have a root server by hetzner with 1gbit and enough power and at home i have 50mbit download. I use plexdrive and than rclone local to encrypt and fuse mount.

I try plexdrive 4.0 but always by the script plexrebuild-cache from ajki i see an error “Could not open mongo db connection”. ok i switch back to plexdrive 3.0 and plexdrive works but the buffering is a big issues for me.

Mount settings:
/usr/bin/plexdrive $MPOINT
-o allow_other,read_only
-t /root/.plexdrive/temp
-v 3 &>>$LOGFILE &
sleep 10
/usr/sbin/rclone mount --allow-other crypt: /media/crypt &
sleep 3
/usr/bin/unionfs-fuse -o cow,allow_other,direct_io,auto_cache,sync_read /media/hdd2/LOCAL=RW:/media/crypt=RO /media/Media/ &

I try many mount paramters with --clear-chunk-max-size=100G \ and --chunk-size=26214400 \ but after a few minutes all movies buffering.

what kind of movies?
720p? 1080p? x264? remux? mkv? avi?
what do you see in plexpy? is your machine transcoding? what about disable subtitles?
where is your transcode folder? RAM? or local space?

I’m also at hetzner, but I’ve no such problem.
Plexdrive 3.0 worked for me very well, only I had every 2nd day at night a crash
But with 4.0 and mongodb it was solved

Start, play, rewind, backwind also very fast

  • all movies and all series and i prevered 1080p bluray oder remux
  • the most are mkv
  • its directly play
  • usually it is without subtitles
  • transcoding its in the RAM 8GB with /etc/fstab

i have no crashes for weeks but the buffering problem with 3.0 and i try 4.0 with some guides and mongodb runs with service but i have the “Could not open mongo db connection” error.

nobody can help me?
Always after 3-5 days I have to refresh the cache so it works again

did you actually run mongodb from the command line before running plexdrive? (you have to start it manually after a reboot) i had the same error problem till i figured that out : ) working perfectly now.

Hello Everyone,

I followed this tutorial but no’m I’m also trying to use the crypt function. I tried following the tutorial but the first part doesn’t work. I’ve got the second part working (crypt). I just changed the setting to point it to the already running plexdrive mount. But I want to have the auto start function enabled in case of a reboot. So could someone please provide a bit more explanation for the first part of the tutorial?

If I run the code as is, I get an empty plexdrive folder (no files visible) which doesn’t surprise me since I never entered my clientid & clientsecret. any ideas’s?

Thank you!