Best conf for Plex? Local cache or VFS?

#1

Hi there guys!

Recently started to use rclone for GDrive + Plex and like saw some post on the web that is better to use VFS, so i need your "help"! What to use better? Basically i will stream 4K TV Series/Movies. What to use? What would be better? VFS or local cache?

P.S maybe smth like if its via VFS

rclone mount -vvv --allow-other --dir-cache-time 48h --vfs-read-chunk-size 1G --vfs-read-chunk-size-limit off --checkers 10 --user-agent somethinggoingon --buffer-size 0 MyMount: ~/GDrive/

Or local cache?

rclone mount -vv --buffer-size 0 cache: ~/mountedfolder/

P.S.S I need for better speed/performance/for fast scan.

Regards

#2

For me personally vfs cache is faster, but you can test both and see which one is best for you. For vfs though I would use 128M as 1G seems really big and there wouldn't be a benefit for streaming.

#3

Thank you for ur answer! If i will use VFS, then how to mount it? Im still need to configure local cache or there is some other ways to mount it?

P.S oh, my fault, understood how to point it.

Maybe you could send your command? Or u have the same? Should i use --vfs-cache-mode?

#4

See OP for his VFS mount commmand

#5

My use is Plex but I use mergefs to write everything locally and upload at night as I find that works better for me.

rclone mount gcrypt: /GD --allow-other --dir-cache-time 96h --log-level INFO --log-file /opt/rclone/logs/rclone.log --timeout 1h --umask 002 --user-agent something --rc
#7

Understood. Thanks! Would u reccomend me to use --vfs-cache-mode or nah?

#8

For my setup, it doesn't make sense to use it. Some people write directly to the mount and use vfs-cache-mode writes, any other setting would make streaming awful as it has to grab the whole file before streaming.

#10

Animosity- your mount script is blazing and works great for me when I load it manually. However when I try to load the service with the same command it starts to fall apart for me. It seems like it tries to make multiple rclone service starts and then the mount falls off. I'm not using the crypt so I changed it for cache? Could that be the problem?

Also I can't seem to get the mergerfs to work in Ubuntu. Should it mount any different than the Arch distribution?

#11

I'd probably make a new post and include your details as it should work without much issue on Ubuntu as well.