Bad Status - Plex Web socket

Hey gang,

Switching over from plexdrive to rclone cache and it seems to work really well so far. I configured a cache remote per instructions but I’m getting this error in the syslog when accessing media. Doesn’t seem to stop things but I’m not sure if it’s a big deal:

gdrivetvcache: Connected to Plex server:
Jun 22 16:59:04 gringotts-plex rclone[25595]: plex: websocket.Dial ws:// bad status

$ rclone --version
rclone v1.42

  • os/arch: linux/amd64
  • go version: go1.10.1

My server has https connections set to preferred, but not required.

Where should I start looking?

I’d stop everything. Delete the plex stuff out of your config.

Run rclone config to add in the URL/Username/pass and restart it up.

You normally just need the port:

Jun 17 21:13:06 gemini rclone[19820]: gcache: Connected to Plex server:

I’m not sure what you mean by just needing the port, at the setting in clone requires a complete url for the server. I tried using localhost but am getting the same result.

$ nc -zv 32400
Connection to 32400 port [tcp/*] succeeded!

Jun 23 10:43:14 gringotts-plex rclone[28151]: plex: websocket.Dial ws:// bad status

$ nc -zv 32400
Connection to 32400 port [tcp/*] succeeded!

I put in the username and password. Is that correct?

Incidentally, when I issue curl against the plex server URL locally, using the Plex token, I do get data back:


<?xml version="1.0" encoding="UTF-8"?>

<MediaContainer size=“23” allowCameraUpload=“1” allowChannelAccess=“1” allowMediaDeletion=“1” allowSharing=“1” allowSync=“1” allowTuners=“1” backgroundProcess
ing=“1” certificate=“1” companionProxy=“1” countryCode=“can” diagnostics=“logs,databases,streaminglogs” eventStream=“1” friendlyName=“Gringotts” hubSearch=“1”
itemClusters=“1” livetv=“6” machineIdentifier="…" mediaProviders=“1” multiuser=“1” myPlex=“1” myPlexMappingState=“mapp
ed” myPlexSigninState=“ok” myPlexSubscr

So it’s not a connectivity issue. Something is returning a ‘bad status’. Is there an deeper level of logging I can turn on?

What specifically is in the line in your rclone.conf:

Mine is:
You have to use rclone config to enter in this info, don’t do it by editing the file.

plex_url =
plex_username =
plex_password = yourpassword

After your connect, you get a token entry in your rclone.conf with the token. You don’t add this manually.

plex_token = tokenappears

type = cache
remote = google:tv
plex_url =
plex_username =
plex_password = thepass
chunk_size = 10M
info_age = 1h
chunk_total_size = 10G
plex_token = thetoken (I did not enter this)

You don’t need the rest of the url after the port number.

1 Like

Well that was it!

Thanks so much,