Backblaze bucket size much larger than PC directory

I just started using rClone with Backblaze to backup my Mint Linux system. I have used rClone to backup a test folder, about 3GB for the last month before migrating my full backup. Last weekend I moved my full system over. It should have been about 550GB of data from a single directory. I was surprised when it completed and my B2 Bucket showed a “Current Size” of over 950GB! What caused this to be so large? The command I used is listed below:

rclone sync --fast-list --delete-during --transfers 4 --checkers 8 --contimeout 60s --timeout 300s --retries 3 --low-level-retries 10 --stats 1s /media/bob/TBDrive/Backups/bob Backblaze_B2:TBDrive/bob

I just found the --fast-list to help solved the Class C transactions. I don’t see any reason why the bucket size is so much larger than the directory on my PC. I even checked my directory with several methods just to make sure I wasn’t missing anything.

Love to hear your ideas. I don’t want to have to pay for twice the data I am backing up. - Thanks!

I guess it might be b2 versions. By default b2 stores files you have deleted as old versions. Check that link to see how to discover whether it is or not and if you never want versions use the --b2-hard-delete flag.

I will check on that. This was an initial upload into a new bucket, but that doesn’t means something isn’t going on there.


So, I ran an rclone cleanup and it paired it down to what I was expecting. I have no idea why there were version data for this upload, but it apparently did. Thank you very much for pointing me in the right direction. I wouldn’t have ever tried that on my own.

Great - glad it is working as expected now!

You can control the versions with b2’s bucket lifecycle tool too