B2 TestObjectRemove failing on master branch


I am running the b2 unit and integration tests for the first time. I have set up a brand new application key with all account permissions enabled. When I run “go test -v” as described in CONTRIBUTING.md I get the following:

Any suggestions or tips?

Is that for unmodified code?

It looks like it failed to remove the object (that is what the test is for) and hence it appears in the listing.

Does the app key have delete permissions?

You can check the status of the daily integration tests here: https://pub.rclone.org/integration-tests/

B2 is running fine :slight_smile:

Hi ncw, thanks for responding.

Yes I got the same fail on a fresh install of rclone master. I uploaded a pastebin terminal log here: https://pastebin.com/6jeWjTfh

The log shows creation of a brand new key with all possible permissions granted using the b2 cli tools, and then applying that key to the TestB2 configuration using ./rclone config

Then I run the b2 tests, and brrrt. Same error. Would appreciate your input. Please let me know if you want me to provide any other details.

If you run the tests with -dump-bodies then rclone will print the http transactions. It will be rather verbose but that may gives us a clue as to what is going on.

What appeared to have happened is that we deleted the object, b2 said 200 OK, but then it wasn’t deleted - that is what that test does.

That test works fine with the account key, so it is some difference between that. It might also be a bug at b2 and if it is, I know the right person to email at b2!

I think you’ll need to add -verbose also to the tests.