AWS Snowball Configuration Issues

What is the problem you are having with rclone?

I cannot correctly configure Rclone with my AWS Snowball Edge device

What is your rclone version (output from rclone version)

rclone v1.55.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04

Which cloud storage system are you using? (eg Google Drive)

AWS Snowball (S3)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo rclone ls norcalsnowball:evt-lect-test/

The rclone config contents with secrets removed.

type = s3
provider = Other
env_auth = false
access_key_id = *redacted*
secret_access_key = *redacted*
endpoint = https: //192. 168. 1. 111:8443
acl = private
bucket_acl = private
upload_cutoff = 5G
chunk_size = 15M
max_upload_parts = 10000
copy_cutoff = 4.656G
disable_checksum = false
profile = norcalsnowball
upload_concurrency = 4
force_path_style = false
v2_auth = false
list_chunk = 1000
no_check_bucket = false
no_head = false
disable_http2 = false
region = snowball

A log from the command with the -vv flag

2021/04/20 11:25:15 DEBUG : Using config file from "/home/evtoffice/.config/rclone/rclone.conf"
2021/04/20 11:25:15 DEBUG : rclone: Version "v1.55.0" starting with parameters ["rclone" "-vv" "ls" "norcalsnowball:evt-lect-test/"]
2021/04/20 11:25:15 DEBUG : Creating backend with remote "norcalsnowball:evt-lect-test/"
2021/04/20 11:25:15 DEBUG : fs cache: renaming cache item "norcalsnowball:evt-lect-test/" to be canonical "norcalsnowball:evt-lect-test"
2021/04/20 11:25:15 DEBUG : 2 go routines active
2021/04/20 11:25:15 Failed to ls: RequestError: send request failed
caused by: Get "https: //evt-lect-test. 192. 168. 1. 111:8443/?delimiter=&max-keys=1000&prefix=": dial tcp: lookup evt-lect-test. on no such host

I'm attempting to transfer from a local snowball to OpenStacks swift, using Rclone, but I'm having trouble configuring Rclone correctly to work with the snowball. I am able to use the command: sudo rclone lsd norcalsnowball: to correctly list all the the buckets on the snowball, but I get this same RequestError any time I try to do any other command.

Also please note I had to add spaces in the url's to be able to create the topic without any links in it.

Any help would be much appreciated.


hello and welcome to the forum,

rclone is trying to locate the bucket evt-lect-test
looks like some kind of dns issue, cannot find evt-lect-test.

sorry, not sure the solution but i would try removing --s3-force-path-style

Hi jojothehumanmonkey,

I tried setting the force_path_style = true, to toggle it from where it was before, as it was false, and the ls command is now working as expected. I'm off to try doing a full copy to Swift.

Thank you so much! I'll report back if it works or not for the full transfer


SUCCESS! - I just tried syncing a transfer that I had previously had issues with using Minio-Client (and the Swift S3 API) and it was able to properly sync without any issues.

Thank you again for the help!

sure, glad to help

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.