Automator move file permissions

What is the problem you are having with rclone?

Complete newbie to rclone. I have rclone mounted on my m1 Mac via MACfuse. I setup a automator folder action to automatically move a file from my ssd to a folder on the rclone drive mount and it says I don't have permission but I can move and copy files to the mount via finder no problem. any help would be so greatly appreciated.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.2

  • os/version: darwin 13.0.1 (64 bit)
  • os/kernel: 22.1.0 (arm64)
  • os/type: darwin
  • os/arch: arm64
  • go/version: go1.18.6
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount drive:/ ~/drive --daemon --vfs-cache-mode full --poll-interval 60s --allow-other```

to debug, try adding ‘get specified Finder items’ to the top of your Automator action, add a file to the action, then run manually and check the output under ‘result’

Added it to the top and this was the error.

Move finder items encountered an error. Could not move because you don’t have permission to access “Uploads Folder”

temporarily add Automator to Settings > Privacy & security > Full disk access and test again

If that doesn’t work then right click > get info ‘Uploads folder’ and check permissions

If it’s ‘custom access’ run ls -l@ <parent of Uploads folder> (redact anything private) e.g. ls -l@ ~/

I tried both and I believe I did them correctly without success. Is that last command for permissions?

When I run that command I believe I get total 0

This is what the Upload folder shows

drwxr-xr-x 1 mediaserver staff 0 (date) (Folder name)

I’m thinking I need to give full permissions to (everyone) and not just (mediaserver)?

But I have no clue how to do so?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.