Asustor NAS Portainer docker setup and mount

I have an Asustor AS6204T NAS, with Portainer installed. It should be a low-resource solution to install rclone in a docker.
Can someone help me how can I setup the rclone docker and mount a google drive using Portainer? Possibly with a solution that remains stable after a restart as well.
As Portainer is available for other systems, it should not be a solution only for Asustor system but various NAS could use it.
Thank you very much in advance.

hello and welcome to the forum,

here is the documentation

Indeed I started with this description. I used this install guide without any issue when I installed it on a windows machine. On the other hand, when I tried to install it to my NAS via Portainer I couldn't configure it properly. After the container cofig it won't start, just exit immediately with "exit code 1". This is why I'd like to ask for a specific "install guide with portainer".

have you searched the forum for portainer, as there are a bunch to posts about it?

Yes, I have serched for it. Unfortunately most of them are about a specific issue, related to just a small detail in config, or the other users also tried to ask for a guide but the same link has been suggested to use.

Any other suggestions on this topic?

Hi szamy1,

I have no experience with Docker or Portainer, but I am ready to give you a helping hand to get past your “exit code 1” (Syntax or usage error).

Are you able to give to give me a simple guide to create a Portainer with rclone where I can see and troubleshoot the error you see now?

I am on Windows with WSL2 (Ubuntu-20.04), Visual Studio Code, etc.

1 Like

Thank you Ole. I appreciate your offer! On the other hand, I think the issue is not really with the "exit code 1". The docker should be configured properly in portainer, and it should be accessed somehow on the linux system. This whole step-by-step process is what I'm looking for.

You are welcome, that's fine.

What are the steps you have already taken/tried and what are the steps your are missing?

If you share that, then we/I will be able to follow in your footsteps and hopefully help you with the remaining/missing steps.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.