Arm 64 Bit for Windows

What is the problem you are having with rclone?

I have a Microsoft Surface Pro X which uses an ARM 64 bit chip, but runs Windows. Might it be possible to get a build for this combination of OS and instruction?

What is your rclone version (output from rclone version)

rclone v1.57.0

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

The rclone config contents with secrets removed.

A log from the command with the -vv flag

hello and welcome to the forum,

i do not have an answer about that.

as possible workarounds, have you tried
--- use the 32bit windows version of rclone.
--- use WSL2 and run rclone on that.

No as GO isn’t supported on that stack but you can run the intel version I believe.

Actually it looks like windows/arm64 is now supported by go1.17 which I'd missed

$ go tool dist list | grep windows

I build a test build here - can you give it a go?

Note that this won't support rclone mount - I'm not sure whether WinFSP supports arm64 yet, and I'd need to work out how to set up a cross compiling development environment on GitHub actions for it to work which sounds like quite hard work.

This seems like it should probably be an official build for rclone so can you open a new issue on Github about this.

Given that it won't support mount for the time being is this useful enough?

Thanks. I found a few open issues, which said no, but I just searched more and found closed ones saying yes...I see it in the later release notes now as well.

1 Like

Tested the build - seems to work flawlessly.
rclone mount fails as expected.

This is tremendously useful! There must be dozens of us using a Microsoft Surface Pro X!

1 Like

Good, glad it worked.

Can you open a new issue on GitHub and we'll make the support official.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.