Anyone using an rclone mount through Ocaml Mount for encryption?

It seems to work through the samba share. I am able to browse around but as soon as I try to play a file through Plex the whole thing freezes up and the only way to browse files is to reboot the Ubuntu VM. When that happens it looks as if the whole mount is frreezing. I am not sure if its rclones mount or ocaml but am wondering if anyone else does this with success? All my data on gdrive is encrypted soI have to use an rclone mount. What are my other options?

I've been using with very good results.

Did you change of the config for the streaming?

There is a post here that a bit down talks about some settings to change to help and that worked wonders for me.

I did change the config file. You have had success with the rclone mount pointed to the encrypted ocaml mount?

Yep. I’ve been watching shows over the last few days:

google-drive-ocamlfuse 8.0E 17T 8.0E 1% /GD
TV: 1.0P 0 1.0P 0% /media/TV
TV_Ended: 1.0P 0 1.0P 0% /media/TV_Ended
Movies: 1.0P 0 1.0P 0% /media/Movies

My rclone mount looks like:
/usr/bin/rclone mount --allow-other --read-only --default-permissions --uid 1000 --gid 1000 --umask 002 --acd-templink-threshold 0 --buffer-size 1G --timeout 5s --contimeout 5s --syslog --stats 1m -v TV: /media/TV

I think I’m double buffering somewhere, but I’m afraid to change anything as it’s just working superb.

I wonder if its the samba share on top of all this causing the issues. I tried it again and it looks like I can browse the share within ubuntu on the mount but windows file share has completely froze.

I’m all local on a Fedora Linux box with the fuse mount/rclone and plex.

Just to make sure, i replaced everything after “remote =”

from this is looks like im supposed to keep gdrive: ?

type = crypt
remote = gdrive:**crypt -> change it to** /mnt/your-ocaml-mount
filename_encryption = standard
password = ***
password2 = ****

Yep. That’s exactly what I have.

I have it mounted to /GD on my system and then my folder is actually encrypted so it has a funky name:

type = crypt
remote = /GD/media/d93daonsmv845k5s40knr5mf4s

Why do you mount read only? I have file bot that I use to rename my files and place them into the correct directories.

I only use rclone move/copy to make changes. I try not to alter the mounted filesystem directly as that seems to create issues.