Any clear file name length when using crypt?

What is the problem you are having with rclone?

I mounted a local crypt and began to copy files into it. Then I ran into the file name limit issue which has been discussed here previously. I found ~143 characters mentioned as a limit here:

Thus I did some quick find and grepping to locate all files with names of 140 characters or more and simply renamed them or zipped the directories depending on what made sense. So far so good but then I copied some more and noticed that the limit isn't necessarily consistent. It's understandable that the encrypted names vary but thus I now wonder:

  • what limit would be more or less guaranteed to work?

  • will I get problems with files that exceed that limit even though they were copied successfully now?

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: ubuntu 22.10 (64 bit)
  • os/kernel: 5.19.0-35-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive but I ran into this when trying to make a local encrypted backup.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I already had a local crypt mounted and ran into this when copying to it. Both the drive with the crypt and the source use ext4.

The limit is deterministic and absolutely fixed.

However not all characters are created equal. Rclone is using the UTF-8 encoding so some characters which appear as a single character to you, eg é will appear as two characters to rclone. I suspect this is where you see differing limits.

143 characters of UTF-8 encoded

No. If they copied over then all is good!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.