Another onedrive university account problems

What is the problem you are having with rclone?

I tried to connect to university onedrive account, because there is no one to authorize the api access, the only way to do is to use the webdav method to connect, same as other similar situation people ask here before. But still I have no luck to connect to my onedrive account.

Below is what I have done:

  1. use the webdav sharepoint method to connect to my account, no luck.
  2. extract the required cookies(rtFA,FedAuth) from browser and connect using davfs, and then create rclone crypt volume to local path, successful but not a good solution.
  3. use --http-headers and --webdav-headers and --use-cookies to set cookies(rtFA,FedAuth) for every rclone command, no luck
  4. By looking at some of the past questions, it seems that even the webdav method need to use microsoft graph api to access, I tried to login graph api site, but it need another authorization.

By looking at the request dump, it seems that the cookies is not set at all, may I know:

  1. I check the source code, the rtfa and fedauth cookies should be auto generated according to rclone config user/password, but how can I confirm if it is really generated? is it stored in a file?
  2. Is there anyway I can just set the cookies myself, just like what I did using davfs mount?
  3. Can I confirm that base on the following request dump, the cookies is not set in the command?

Thanks a lot.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.0

  • os/version: fedora 34 (64 bit)
  • os/kernel: 5.11.12-300.fc34.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.8
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Onedrive, but use the webdav method

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd HKU: -vv --dump requests

The rclone config contents with secrets removed.

type = webdav
url =
vendor = sharepoint
user = XXXXX
pass = XXXXX

A log from the command with the -vv flag

2022/03/28 13:44:32 DEBUG : rclone: Version "v1.58.0" starting with parameters ["rclone" "lsd" "HKU:" "-vv" "--dump" "requests"]
2022/03/28 13:44:32 DEBUG : Creating backend with remote "HKU:"
Enter configuration password:
2022/03/28 13:44:36 DEBUG : Using config file from "/home/louis/.config/rclone/rclone.conf"
2022/03/28 13:44:36 DEBUG : found headers: 
2022/03/28 13:44:36 DEBUG : You have specified to dump information. Please be noted that the Accept-Encoding as shown may not be correct in the request and the response may not show Content-Encoding if the go standard libraries auto gzip encoding was in effect. In this case the body of the request will be gunzipped before showing it.
2022/03/28 13:44:36 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2022/03/28 13:44:36 DEBUG : HTTP REQUEST (req 0xc00063c500)
2022/03/28 13:44:36 DEBUG : POST /extSTS.srf HTTP/1.1
User-Agent: rclone/v1.58.0
Content-Length: 1384
Accept-Encoding: gzip

<s:Envelope xmlns:s=""
<a:Action s:mustUnderstand="1"></a:Action>
<a:To s:mustUnderstand="1"></a:To>
<o:Security s:mustUnderstand="1"
<t:RequestSecurityToken xmlns:t="">
<wsp:AppliesTo xmlns:wsp="">
2022/03/28 13:44:36 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2022/03/28 13:44:36 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/03/28 13:44:36 DEBUG : HTTP RESPONSE (req 0xc00063c500)
2022/03/28 13:44:36 DEBUG : HTTP/1.1 200 OK
Content-Length: 1447
Cache-Control: no-store, no-cache
Content-Type: application/soap+xml; charset=utf-8
Date: Mon, 28 Mar 2022 05:44:36 GMT
Expires: -1
Pragma: no-cache
Set-Cookie: fpc=Ap8kZpqkx6hEr7hPNUX5tUJd4aY_AQAAAENC09kOAAAA; expires=Wed, 27-Apr-2022 05:44:36 GMT; path=/; secure; HttpOnly; SameSite=None
Set-Cookie: x-ms-gateway-slice=estsfd; path=/; secure; samesite=none; httponly
Set-Cookie: stsservicecookie=estsfd; path=/; secure; samesite=none; httponly
Strict-Transport-Security: max-age=31536000; includeSubDomains
X-Content-Type-Options: nosniff
X-Ms-Ests-Server: 2.1.12570.11 - SEASLR1 ProdSlices
X-Ms-Request-Id: 484ca20d-c48c-4f58-9f96-ea83dd8b4300

2022/03/28 13:44:36 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2022/03/28 13:44:36 Failed to create file system for "HKU:": wst:FailedAuthentication: Authentication Failure (AADSTS50126: Error validating credentials due to invalid username or password.)

Use -vv --dump headers and you'll see exactly what rclone is sending.

Using --web-headers should work - check the requests look OK with -vv --dump headers.

It doesn't look like it - I don't see any Cookie headers in the request.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.