Android/termux rclone connection refused, it used to work

OK so out of the blue i am starting to get the connection refused thing again on android termux.
I had been using this for month with stable 1.35.
Could a termux update have caused this?

I suppose so, but I didn’t understand why it did it in the first place.

What exactly is the error?

Sorry for the delayed response. I was AFK

Running any command like this

rclone ls enc:

Throws an error like this.

2017/03/06 02:30:52 Failed to create file system for "enc:": failed to make remote "ACD:rclone" to wrap: failed to get endpoints: Get Post dial tcp: lookup on [::1]:53: read udp [::1]:39491->[::1]:53: read: connection refused

This was a problem back in the day.
I am not sure how it got fixed but it just started working one day.
The error showed back up. I tried on 1.35 and 1.35B158
I know it worked on 1.35 forever so thats why i though maybe it was an update in termux.

rclone ls ACD:
Also fails. nothing to do with the encryption layer.

and not to confuse the matter more... but it works when my hotspot is on. Just like it did back in the day.

How did you build rclone?

This is probably the most relevant Termux issue I can find:

If you are just using the linux-arm binaries I build then these will give this problem - you’ll need to build rclone yourself using the go installed by apt install golang

I mean i guess the thing is this was broken… then started working… now is broken again.
I was using the 1.35 stable the entire time.
I will take it up with turmex :slight_smile: Thanks for the awesome tool.

1 Like