after restart i cant see google drive folders anymore

Hi everyone
I installed Rclone on a ubuntu 18.04 server
I was successful with the installation and setting up my google drive
I would say the result is excellent and I congratulate you on this fabulous program
i mounted my folder using this command
rclone mount mygdrive: ~/gdrive/
and I was able to view all the contents of my gdrive cloud
But now I've restarted the server and I don't see any files inside the gdrive folder
i had to run the command again
rclone mount mygdrive: ~/gdrive/
to return to see all its contents
Is there a way that when I restart the server it mounts automatically??
Thanks for any help/answers

welcome to the forum,

same as any linux program. use cron, systemd, etc...

and hard to help, as you did not answer any of the questions???

Sorry, I'm new to the forum and I don't understand what questions I didn't answer
I read what was written when I opened the thread
but I don't know what other information I could include in the topic

ok, no worries, as what you want to do, the forum is full of examples
and is also mentioned in the docs

i assumed that you searched the forum+docs and could not get it working.
so that is why i asked for the same basic info asked of any poster.

and if you are running an old verison of ubuntu, so apt get will install an ancient version.
so i wanted to be sure you are using latest stable v1.63.1

I searched the forum and couldn't find the solution
I thought about adding to fstab but to be honest I don't know much about these configurations
so i was wondering if there is something or some simple but functional solution

Are you using Ubuntu enterprise support program? Otherwise support for Ubuntu 18.04 ended in June this year. There is no point to troubleshoot ancient OS nobody should be using any more.

Nothing about new or not questions are very clear. Here you are reminder:

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

that is also documented at add in /etc/fstab

rclone v1.63.1

  • os/version: ubuntu 18.04 (64 bit)
  • os/kernel: 4.15.0-213-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.6
  • go/linking: static
  • go/tags: none

ok, good.

well, what you asked for, is already documented and discussed in the forum.
just trying to understand exactly what you need help with?

An example entry for fstab is below

For after reboot mount I strongly recommend to investigate and learn systemd. It is the most natural way in linux to manage various dependencies - for example using fstab you risk that mount will fail because computer is not yet connected to the network etc. With systemd you can explicitly define what other OS subsystems have to be fully operational before attempting mount.

ok thanks for your answer
since I'm not very practical with these configurations but google helps a lot in these cases I'm looking for something that could solve
or if by chance you have some guide to recommend, I'm grateful


There is plenty of info out there. But I really recommend trying to understand what you are doing. Copy/paste approach from random sources on internet is clear recipe for disaster.

Good start to read:

Wikipedia - systemd - Wikipedia

Very good Linux documentation - systemd - ArchWiki

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.