ACD oauth proxy broken!


#22

Thank you s20p17a1m14 for this hint! I’m now using it on a Google Cloud Compute instance with Windows Server on it. It’s a pity that I can’t use rclone any more! I hope that there will be a solution for this problem with Amazon soon because I want to use rclone again.
Again: Thank you Nick for your great work!


#23

is the oauth proxy fixed already? it’s still broken on my side


#24

In case this ever gets fixed, what’s the best guide on how to set this up? I’m reading over at
https://rclone.org/amazonclouddrive/
and the instructions say rclone config will “guide” me through things, but well, I don’t even know what a client_id and client_secret are.
I guess I’m supposed to read and comprehend this first?


is that correct? Meaning I have to run my own proxy? or is there some default proxy someone else had setup? or am I misusing the word proxy in the first place?

Current plan of course is to use something like odrive or airexplorer if I can’t figure out rclone, I’ve still got 40days or so to move 20tb, fingers crossed I can make it.


#25

@left1000 Please see this for the answer to most of your questions.


#26

Thanks, @boldn and @ncw. Does anyone have plans to resolve this issue?


#27

Ah, just seen this after posting my other thread. :frowning:

Hope we can come up with a solution…


#28

Any advice for someone with encrypted files on ACD? I don’t think AirExplorer or odrive allow you to decrypt. I was about 1/3rd of the way through migrating the data of ACD before it stopped working. Honestly if I could just get a list of all the files I had I could probably redownload what’s missing from elsewhere.


#29

You’re probably going to have to download using a different client…

I’m finally biting the bullet and switching to Synology Cloud Sync. It doesn’t work anywhere near as elegantly or fast, but if it’s all that works, I don’t have much choice.


#30

If you are willing to spend some time, you could try find the client_id and client_secret from another program.
There are other ACD Desktop clients out there which may have them stored unencrypted somewhere.


#31

Problem with that is that as soon as you find them, everyone will jump on them and then they’ll end up being killed too. So it’s not a long-term solution.


#32

I think most people are not interested in long term solutions, as ACD Unlimited is dead and they are just hoping to get their files back.


#33

Didn’t everyone already get their files back using the Rclone Auth proxy, after the last time ACD was ‘dead’? Seems careless to not have a local backup when this is the second time it’s happened. :wink:


#34

Yes : Definitely migrate everything elsewhere. I have got less than 2To so it’s easier for me.


#35

thanks. that answered all my questions perfectly, and now I’ve got things configured correctly to experience the same error as the rest of you :slight_smile:


#36

I know, it’s a bit off topic but:
I’ve downloaded roughly 5TB in around 12 hours from ACD and now I can’t download anything. It is not only with different applications (tried Syncovery and Air Explorer) but also on the web interface. The downloads simply don’t start. When I log into the web interface there is no message about a lock or something. This is the second time I got this strange behaviour. It unlocked after roughly one day.
Did anyone else have had the same experience?


#37

Does the same for me regardless of app and has done so for about 6 months now. wait a day, and it clears up for another 5 tb


#38

Thank you very much for your reply! It is essential for me for not being totally blocked because my local backup is partially damaged. I can life with 5TB download per day being transferred to Google.


#39

But you cannot transfer more than 750GB/24h to Google…


#40

Yes, this is right. I’m using multiple accounts to transfer to.
Yesterday it was only possible to transfer around 3,7TB. May be, there is some other limit on ACD? Total API requests per user or so?


#41

Hi all, this stinks! :frowning:

I’m in the 180 day period and need to download the balance of my 57 TB to my local NAS (well underway of course), but with a 100 Mbps uplink s that is 59.4 days of downloading (@ 10% overhead), assuming no rate limiting, which of course I was always plagued with.

Two questions:
1. Is there any workaround that has been devised yet, using another auth method?
2. In absence of getting rclone to work again, I’d settle for any conduit to download the balance of my data.
a. I can’t get the ACD client to work, it just spins endlessly.
b. I can’t find any other 3rd party app that will work. Suggestions?

Thanks in advance for your assistance.