ACD is slow after a big copy

I did a lot of traffic from ACD to Google Drive. Like a 900mbit/s flatline with a total of 10TB.
Is there any known rate limiting? Because it’s very very slow now… It’s impossible to watch something. Here is a speedtest:

My mount settings:
/usr/sbin/rclone mount --read-only --allow-other --acd-templink-threshold 0 --stats 1s --buffer-size 1G --max-read-ahead 1G -v --log-file=/var/log/rclone_mount.log media: /plex/acdPlex/.remote

And I use the custom kernel “” to fix the fuse trouble with read-ahead. It worked flawless. But now it sucks big time…

So anybody experiencing the same slowness now? (i’m on eu-west) or is this a ratelimit I hit on my ACD account?

To me this looks similar to my issue. The only difference is that I am uploading rather than downloading. If you turn on debugging, do you see a retry for that file happen up to the limit of the 'retries' variable and then hang? I think once it exceeds to retries, the mount doesn't return a fail to the file system and whatever was trying to read it is waiting indefinitely for an answer from the mount (fail or success).

I found my issue, it looks like that it’s stable again.
To explain my situation, what is quite interesting:

Proxmox host server, that is running my Plexserver and some other VM’s.
I configured wondershaper on the proxmox host to make sure my bandwidth util doesn’t exceed 95% usage.
That caused this issues, as soon as I deleted the wondershaper config it was fixed and stable again.
Really strange…