Accessing Sharepoint Onedrive

What is the problem you are having with rclone?

I'm trying to download some folders from a corporate sharepoint that was shared with me. I've tried using the onedrive and webdav connection and keep running into errors. I tried following this post but got the same results configure-a-sharepoint-onedrive-business-remote-as-a-guest/26991. I can access the share on a browser from https://company.sharepoint.com/personal/Email_domain_com/Documents/Personal/Photos

Run the command 'rclone version' and share the full output of the command.

- os/version: Microsoft Windows 10 Pro 21H2 (64 bit)
- os/kernel: 10.0.19044.1766 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.18.3
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

sharepoint / onedrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls corpShare:Photos

The rclone config contents with secrets removed.

Editing existing "corpShare" remote with options:
- type: webdav
- url: https://XXX.sharepoint.com/personal/XXX_XXX_com/Documents/Personal/Photos
- vendor: sharepoint
- user: MyEmail
- pass: *** ENCRYPTED ***

A log from the command with the -vv flag

2022/07/18 17:57:27 DEBUG : rclone: Version "v1.59.0" starting with parameters ["rclone" "ls" "corpShare:Photos" "-vv"]
2022/07/18 17:57:27 DEBUG : Creating backend with remote "corpShare:Photos"
2022/07/18 17:57:27 DEBUG : Using config file from "AppData\\Roaming\\rclone\\rclone.conf"
2022/07/18 17:57:27 DEBUG : found headers:
2022/07/18 17:57:28 Failed to create file system for "corpShare:Photos": wst:FailedAuthentication: Authentication Failure (AADSTS50034: The user account {EmailHidden} does not exist in the directory. To sign into this application, the account must be added to the directory.)