403 FORBIDDEN WebDev problem


#1

I’m trying to connect to my corporate group disc. So i can upload things there.
The site is like https://corpname.sharepoint.com/sites/groupname/Shared%20Documents/Forms/AllItems.aspx
I give this url while configuration, but i get:

2018/07/30 12:31:32 ERROR : : error listing: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN
2018/07/30 12:31:32 Failed to lsd: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN

when i try to rclone lsd remote: -vv
Can anyone help me?


#2

Looks like you don’t have access as something is configured incorrectly with user name / password perhaps. Can you share the rclone.conf with the passwords and such masked?


#3

Where i need to put this URL? I do that this way:

  1. Create a OneDrive remote with my oneDrive account where I am added to the private group where the files i want to sync with are placed.
  2. Create a webdav and there i put an link like above
    and my one Drive login and password.

My conf files are:

[remote]
type = onedrive
token = {“access_token”:“XXX”,“token_type”:“Bearer”,“refresh_token”:XXX"",“expiry”:“XXX”}
resource_url = https://CORP-my.sharepoint.com/


#4

[test]
type = webdav
url = https://CORP.sharepoint.com/sites/GROUP_NAME/Shared%20Documents/Forms/
vendor = sharepoint
user = name.sur@comp.com
pass = my_sharepoint_passw
bearer_token =

Sorry for 2 posts but i couldn’t add 2 URL in one post as a new user.


#5

Can You help? I would really like to know how to do it.


#6

I don’t use Onedrive at all so sorry I don’t see anything offhand. Perhaps someone with a Onedrive could help?


#7

Sorry for the delay in responsding.

Try cutting the url down in your config

url = https://CORP.sharepoint.com/sites/GROUP_NAME/

Does that work?


#8

I have to set this url in webDAV or in OneDrive conf? In webDav it didn’t help :frowning: Any other idea?


#9

In the WebDAV config.

Try this

url = https://CORP.sharepoint.com/sites/GROUP_NAME/Shared Documents/Forms/

And see if it makes any difference (So replace %20 with a space)


#10

Still same error :confused:
2018/08/07 16:53:45 ERROR : : error listing: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN
2018/08/07 16:53:45 Failed to lsd: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN


#11

Can you try your original config with -vv --dump bodies and paste the output of that?


#12

X-Msdavext_error: 917656; Access+denied.+Before+opening+files+in+this+location%2c+you+must+first+browse+to+the+web+site+and+ select+the+option+to+login+automatically.
Is it posible at a CLI and linux?


#13

Hmm, I don’t know what is happening here!

Did you try setting up access to your sharepoint account as a “ondrive for business” account? That might work better.


#14

I am getting the same thing when trying to use webdav to upload to onedrive.
type = webdav
url = https://place-my.sharepoint.com/personal/tyler_dey_place_edu/documents
vendor = other
user = tyler.dey@place.edu
pass = *** ENCRYPTED ***

PS C:\WINDOWS\system32> rclone -vv ls tyler_dey:
2018/08/10 16:10:45 DEBUG : rclone: Version “v1.42-091-g6156bc58” starting with parameters [“C:\WINDOWS\system32\rclone.exe” “-vv” “ls” “tyler_dey:”]
2018/08/10 16:10:45 DEBUG : Using config file from “C:\Users\--------\.config\rclone\rclone.conf”
2018/08/10 16:10:49 ERROR : : error listing: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN
2018/08/10 16:10:49 Failed to ls: couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN


#15

@czech1900 Have you solvled this issue? I have same problem.
I can’t access /mnt/od1 whenever the “rclone mount” running time is close to 24 hours.

Error Message
ls /mnt/od1/
ls: reading directory ‘/mnt/od1/’: Input/output error
The debug error message for rclone mount is :
rclone[5204]: /: >ReadDirAll: item=-1, err=couldn’t list files: 403 FORBIDDEN: 403 FORBIDDEN
X-Msdavext_error: 917656; Access denied. Before opening files in this location, you must first browse to the website and select the option to login automatically

This is my comand and webdav sharpoint config
rclone mount --dump headers --log-level DEBUG --allow-other od1: /mnt/od1 --syslog --rc
my rclone config for webdav sharepoint
[od1]
type = webdav
url = https://xxx-my.sharepoint.com/personal/xxxx_edu/Documents
vendor = sharepoint
user = xxxx@xxxx.edu
pass = xxxxxxx


#16

I make a issue in github:
rclone mount with sharepoint(webdav), Got 403 FORBIDDEN whenever it running time close to 24 hours


#17

Ah, so it did work then stopped working? That probably means the token expired.

If so can you please make a new issue on github about this?


#18

@ncw, Thanks for you reply.

Yes, it did work at beginning, then stop working after about 24 hours(close to).

I need to kill rclone mount and rerun it make rclone mount working again.

I already make a new issue on github for this:
rclone mount with sharepoint(webdav), Got 403 FORBIDDEN whenever it running time close to 24 hours


#19

Thanks for making the issue - we’ll fix it there :slight_smile: