30 seconds to start playback - 100mbps download speed

I have an rclone mount running in windows - however files take 30 seconds to start playing.

One thing I've noticed is that network activity doesn't really start for 20-25 seconds after pressing play (using Media Player Classic for testing)

Then once I start seeing network activity - the file plays within a few seconds.

What could be causing this?

My rclone mount conditions are:

--allow-non-empty --timeout 1h --dir-cache-time 8760h --attr-timeout 8760h --poll-interval 1m --drive-chunk-size 32M --log-level INFO --log-file "C:\Users\***\.config\rclone\log.log"

I have my own API and internet speed is 100mbps down


If you want to know for certain use -vv on the mount and look at the log.

In my experience it will be the media player seeking around the file reading small bits of data to find out about the video file (eg read the bit rate, load the thumbnail etc) - this is quite time consuming as each seek takes a second or two.

Hmm I use the same settings on a Linux server with a 1gbps link and files play within 5 seconds.

Understand 100mbps isnt 1gbps,. but can a file start playing quicker than 30 seconds on a 100mbps link?

But you aren't using the same media player on Linux presumably... that is what Nick is talking about here.
The network connection really isn't as relevant as long as it' sufficient. 100Mbit is certainly more than enough for anything but the most extreme of extreme (like maybe 8K).

For Windows I've had great results with VLC - which is generally considered the best media player anyway. It was also designed from the start to be meant for network streaming. I have several high bitrate 4K test-cases that can start within roughly 3-4 seconds on my 150Mbit.

But I have seen one or two weird cases of spesific formats or file series that can open much slower than others, but this is pretty rare all in all and is more like the fault of the format not being design very linearly.

I'm on Windows with these mount settings:

rclone mount --allow-other --attr-timeout 960h --buffer-size 128M --dir-cache-time 960h --poll-interval 10s --rc --read-only --timeout 1h -v

I use MPC-HC, and it takes about 5 seconds for playback to start, regardless of the file size. This is on a 150/150 connection.

I used Plex on both platforms - direct play. I've also used VLC and Media Player Classic on Windows and get 30 seconds starts on all three, so I don't think the client is the issue.

Out of curiosity, what are your rclone settings in Windows, and do you use WinFSP to mount the drive?

Interesting. I use Media Player Classic on Windows and I'm getting the 30 second start times.

OC'd Ryzen 2700x, 32GB RAM and PCIe M.2 SSD

Are you using WinFSP to mount the drive?

Using WinSFP is the only way to mount on Windows, so yes.

I would first of all just give VLC a shot and see if it's better with that.
You aren't using any caching or anything right?
Also - try more than just one file. As I said, a few video-formats can be a little troublesome, but most will play fast.

to be clear, winfsp is the only way to mount with rlcone.
but there are many others ways to mount from cloud storage on windows.

Yes, latest WinFSP beta from earlier this summer.

  1. could you tell us the exact version of winfsp?
  2. why are you using the beta, perhaps you should try the latest stable version.
  3. right now, there seem to be a bunch of bugs with the lastest rclone, perhaps try an older version.

Ok good to know we're all using WinFSP - was curious whether there was some other method I wasn't aware of.

I'm using the latest Beta (WINFSP 2019.3 B2), which was released in July-19

The beta has a heap of bug fixes and seems to be ok for everyone else

I'm using v1.48 already

Those that have no issues with playback start times on Windows, can I please ask what rclone version your using and your rclone conditions?

I can then mirror those settings to see if it helps

Was your reply meant for me?

I've always used whatever latest version available of both Rclone and WinFsp. Haven't had issues in almost two years. I do like to live dangerously, though :wink:

Jokes aside, I do currenly use the latest stable Rclone due to a bug.

See my first reply for my Rclone settings. Using 1.49.5 right now.

Thanks mate will replicate your settings. Will see how I compare to your 5 second start time

What client are you using?

Straight from Windows Explorer to MPC-HC with LAV and madVR. Nothing else.

1 Like

Unfortunately VBB's settings are even worse. Updated to the latest version of rclone (1.49.5).

I just timed it MPC-HC to play a 5GB movie

It took 46 seconds for rclone to get close to max my 100mbps connection - and the file started playing at about the same time.

The prevailing 46 seconds saw my internet connection spike up and down, up to about 12mbps at it's highest.

Tried VLC and it took about 38 seconds.

And this is roughly consistent for all types of media? Same problem on even say - a music file?
Just trying to get an idea of what the problem is.

When you see your network usage going in spikes it means your application (player) is not asking rclone for all the data at once. For some reason it is asking for lots of little bits here and there, and each request will take maybe a second or so to complete due to latency. This typically indicates a file format that is not very linear and maybe not ideal for streaming, but sometimes it can also be the fault of the player because it is not just trying to play the file but also collect various other information from the file (that reside in other areas of the file, making rclone have to jump around a lot).

Using a larger buffer-size isn't really going to solve this sort of problem.

I haven't tried, although I would assume the entire file would download fairly quickly. I'll have to upload a music file to test this.

I'm using MKV files - which seem to play fine from my linux rclone mount (different machine/locality - 1gbps connection)

I tried Plex, VLC and MPC and all take 30+ seconds to start playing.

Is there a certain way to set up WinFSP that I may have missed?

Not really. You could pass special parameters to it via an rclone flag to make it behave differently, but no such thing is required to do what you want and it is very seldomly used outside of spesific debugging and such.

I think you should take his advice and make a -vv log . This will tell us exactly what is going on inside rclone and thus why it is taking so long - then we can stop speculating and "shooting blind".

When I say "us" I mean someone who is better at reading the logs than me probably hehe... I will give it a shot, but I am still only a novice at decoding the debug logs as they are fairly complex.