3 GB File transfer fails because "file is too big" using raspberry pi 4 4GB

What is the problem you are having with rclone?

3 GB File transfer fails because "file is too big" using raspberry pi 4 4GB

What is your rclone version (output from rclone version)

rclone v1.57.0

  • os/version: raspbian 10.11 (64 bit)
  • os/kernel: 5.10.63-v8+ (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy gdrive:path to file --drive-shared-with-me /mnt/nfsShare

The rclone config contents with secrets removed.

type = drive
scope = drive
token = {"access_token":"...","token_type":"Bearer","refresh_token":"...","expiry":"2021-11-19T15:17:27.084547439Z"}

A log from the command with the -vv flag


i tried in a vm running kali and rlcone 1.53.3 ad it works fine, what's the matter with my raspberry?



What is that mountpoint?

hello and welcome to the forum,

could be that there is enough free space on you pi to download the file
are you sure the pi has enought free disk space?

i also have a pi4, ran into lack of fref space, so i now boot from external usb ssd drive.

Also, the command you shared doesn't match your log file:

2021/11/19 14:26:36 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "copy" "gdrive:Anthony Bourdain The Layover/The Layover with Anthony Bourdain S01E07  - Amsterdam 1080p WEB-DL DD+ 2.0 x264.mkv" "--drive-shared-with-me" "-vv" "/mnt/stor02video/Anthony Bourdain - The Layover/"]

That goes to /mnt/stor02video and not /mnt/nfsShare

it's a nfs share on my nas

''' 927G 381G 545G 42% /mnt/stor02video

yep, also mine is booting from a 256GB ssd but the mountpoint is on my nas

sorry, my fault, i tried to type the actual mountpont

Your NAS is returning the error that the file is too large.

Do you have quotas? Do you see any errors on the NAS? What file system is it? What NAS is it?

it's a netgear, it doesn't have quotas.
as i mentioned i run the same command in a vm running kali and the same file has been copied without errors, same if i copy the file via SMB with windows

SMB on Windows is very different from SMB on Linux.

What file system is it on the NAS?

Did you try the same copy from Windows with rclone? Same results?

sincerely i don't know what's the file system it's using, it could be something Netgear propietary since i used x-raid.
i didn't try rclone on win, now i'm trying another file on both the vm and the raspi with -vv enabled, will paste log in 15 mins.

vm to NAS - ─# rclone copy gdrive:Anthony\ Bourdain\ The\ Layover/The\ Layover\ with\ Anthon - Pastebin.com
raspi to nas - root@raspi4:~# rclone copy gdrive:Anthony\ Bourdain\ The\ Layover/The\ Layover\ - Pastebin.com

same NAS, share, source google Drive, file, network, internet connection

Looks like the NAS is telling you something different from Linux vs Windows.

2021/11/19 10:03:05 DEBUG : preAllocate: got error on fallocate, trying combination 1/2: operation not supported

That means it's a file system doesn't support preallocate which is a bit odd.

Perhaps you are hitting a 2GB file limit from Linux to the NAS.

Can you try to just copy a local file perhaps and see if less than 2GB works as this looks to be more something NAS/SMB related than anything with rclone directly.

need to find a file smaller than 2 GB.

anyway you are right: i tried to copy the 3 GB file from Google Drive to local ssd and then to the nfs share with the same error.
I assume this is something related to raspberry os because, again, kali works fine.
will investigate more tomorrow, thanks for your support!

I'd guess you are using NFSv2 or earlier which have a 2GB file size limit.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.