2 flags that allow you to use a normal folder on a remote, as if it were a recycle bin

I would be willing to make a contribution or donation, so that two flags are implemented so that it allows configuring any normal folder of a remote, as if it were a recycle bin, so that, when these flags are used, do this:

That each file that you want to use delete, deletefile, purge, or delete a file or folder, from the windows file explorer, instead of being deleted, move to that normal folder, which will be used as if it were a paper bin.
(Thus, each user, who has, their own normal folder, which has been configured as if it were a recycle bin).

And another flag, so that if a file is to be overwritten, move to this normal folder, which has been specified in the flag, which acts, as if it were a recycle bin, but it is not for the server. Since it is a normal folder. Which is, as if it were, a pepelera for the user. So I could recover the files, whenever I wanted.
When moving them to this normal folder, the file names would be renamed, with filename_year_month_day_hhour_minute_second.extension

These flags should be able to be used in all Rclone remotes.

Rclone has a flag rather like this already called --backup-dir - check it out! You use the --suffix command to add a year/month/day suffix to the files or choose a different --backup-dir

I just tried, right now, the flag: --backup-dir

  • I have tried it first, mounting plcoud, as a virtual drive P: and adding the flag
    rclone.exe mount pcloud:/ Q: --backup-dir pcloud: "/recycle_bin_01"

and with the windows file explorer, I have deleted a file from the main directory, and it has not gone to the directory "/recycle_bin_01".
Just delete it. But it doesn't move him to "/recycle_bin_01"

  • I have also tried it with plcoud with Rclone Delete,
    rclone.exe delete pcloud:"/ok1.txt" --backup-dir pcloud: "/recycle_bin_01"

The file ok1.txt has disappeared, but has not been moved, to the directory "/recycle_bin_01"

hello,

as per the documentaion, --backup-dir only works with rclone sync/copy/move

What modifications would have to be made, so that it works with:

  • With the Mount instruction.

  • The windows file explorer, when deleting a file or a folder, automatically moves to: THE FOLDER configured as if it were to act, from the Recycle Bin, when mounted with the flag --backup-dir, and also you can also use the flag --suffix.

  • And it will work too, with the instructions:

  • Mount,

  • Delete,

  • DeleteFile,

  • Purge,

  • Copy,

  • CopyTo,

  • Move,

  • Sync.

  • That is, if you try, to a file, delete, overwrite, with a windows file explorer, or with an instruction, move the file or folder, with all its structure, where it puts the flag --backup-dir

perhaps you can send a private message to the primary author, @ncw

Duh, sorry, should have thought of that before suggesting it!

In summary --backup-dir doesn't work for rclone mount. It could be made to work relatively easily I think.