0 bytes after moving files into rclone mount folder

What is the problem you are having with rclone?

After setting up the remote, I used rclone mount --vfs-cache-mode writes REMOTE:BUCKET PATH_TO_DIR --daemon. The folder is mounted successfully and I can see the files. But, when I tried to move a file, let's say foobar.tar into the mounted folder, I'm seeing a dummy file of size 0 on the provider's web console: screenshot here However, the file seems to be synced after an hour or so. Is there a way I can make it sync instantly? Or, an alternative suggestion/method is also welcomed.

What is your rclone version (output from rclone version)

rclone v1.57.0
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: 5.4.0-90-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Backblaze B2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --vfs-cache-mode writes remote:container-one mount_point --daemon
mv archlinux-2021.11.01-x86_64.iso mount_point

The rclone config contents with secrets removed.

--------------------
[remote]
type = b2
account = <removed>
key = <removed>
hard_delete = false
--------------------

hello and welcome to the forum,

the file has to be uploaded using your internet connection.

  1. rclone will copy the file to its local cache
  2. rclone will upload that cached file to the remote.

use rclone move archlinux-2021.11.01-x86_64.iso remote:container-one --progress

Hi,

I'm using rclone in a VPS server. I tried to move the iso file into mount_path on my VPS with the standard mv or cp command, but could you tell me why it doesn't upload instantly and why it shows 0 bytes when I checked it on my B2's console? (on the screenshot) Thanks for the alternative method, I'll consider using it too.

the faster the vps internet connection, the faster rclone can upload the file to b2.

when using rclone mount and a file is moved into mount_path,

  1. that file gets moved into the local rclone vfs cache.
  2. once that file is in the cache, rclone uploads it to b2.

when using `rclone move, the file is moved from local storage direct to b2, not using local rclone vfs cache.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.