Workaround for --checksum on crypt?

i am in a bit of a pickle. i transfered some things with rclone that were not finished downloading, but because they are allocated the disk space and date stamp in advance, now rclone thinks they have transferred.

i know that --checksum doesn’t work with crypt. but is there a workaround?


Hello Green,

I would mount the remote with rclone mount, then run rsync on it (with the --ignore-times or --checksum options, depending on your situation).

– Durval.

Are you sure --checksum doesn’t work with crypt? It might be slower as it has to read/download the file but this is what you want anyway.

Other than that you can do probably cryptcheck and see which files don’t match and nuke those (I assume the files that didn’t finish are as many threads you have, 4-10-16, not that many in the end).

i calculate a .md5 per file using corz checksum