Windows share of a mount

I am trying to make a share of a a mount on windows. When i go to make the share it says it cant see the directory or something similiar. I have tried running rclone as both user and admin and i have tried making the share both as a user an admin. I have also tried the --allow-other.
Anyone have some advice?

I sort of figured it out… I thought that maybe the share was being run as “system” which is one level above “administrator” it appears to have worked doing the following.
I ran two cmd windows as system with the following tool.
psexec -i -s cmd.exe
in one i rlcone mounted the other i did a command line share.
It worked.
But im hoping for an easier way.


1 Like

Hello justusiv,

Is a windows share the only option for you? Windows (10 at least) can view webdav shares just like they’re a network share.

In 1.39, ncw and team introduced the rclone serve webdav command, which allows one to create a webdav server for a local remote. If it’s solely for a firewalled local network, something like:
rclone serve webdav --addr myshare:
Should work ( assuming your ip is, it will start a server on port 8081), but it wont offer any encryption or authentication ( anyone on your network can see it, without a firewall, possibly the whole internet ). If you’d like encryption and/or authentication, you can use Caddy ( ):
In the directory you’re running Caddy from, make a file named Caddyfile with contents like ( replace with your FQDN, and $user and $password with the desired user and password:
proxy /
basicauth $user $password

Derived From -

rclone serve webdav myshare:

Then on port 443 you’ll have a webdav server which (ideally) should only be accessible encrypted and with the user and password you supplied.

Good luck, hope this helps,