Windows mount with cache for Plex

Anyone has good experiance with a cached mount on Windows for Plex and wants to share their your rclone mount settings?

I have the cached mount on Windows, but performance in Plex is pretty bad. Movies are slow to start (takes minutes), but then it runs fine. (but seeks are slow again) If I do a copy from the mounted drive in Windows to a local drive it coppies at 5-6 MB/s.

1 Like

I am having a poor experience. I find it pretty much unusable. I copied the settings @samucamg used in his post about getting nssm to work properly in Windows as a starting point:

I let it sit overnight in case rclone did something similar to plexdrive as far as an initial cache and I let Plex run a scan for that same amount of time.

In Windows Explorer, it will show the top level folders pretty quickly, but any dive deeper than that is met with a message in the window saying “Working On It” for at least 20 seconds. Even just right clicking to check properties is the same. Most of the time windows explorer just hangs and crashes.

Plex just sits there for minutes eventually timing out today - I was able to get a movie to at least start yesterday…

I am going to reboot and try with no parameters except the straight mount with allow-other and see what happens. It seemed to work better before adding all the vfs settings.

Sorry I can’t help - but I can confirm that compared to Linux the mount is unstable on my pc. I wish the Windows Subsystem for Linux would support fuse - I would love to run an rclone mount that way and see what happens. I have no use for it myself, but I’m trying to help a family member get set up without having to either run a virtual machine or pay for a vps.

What Cloud service you are using?
It work pretty fine, with Google Drive, Team Drive and One drive for business

But with google drive, I think it works better with Drive File Stream.

I am using it with Google Drive.
Does “Drive File Stream” work with Plex? How would that look? All I need is a one-way mount for someone to be able to watch files on my drive through Plex. They don’t want to pay for a VPS (which is working perfectly…)

If you have a G-suite or Education account, you can download it. This work fine with me, if you don’t, You can also try another easy alternative, is Rclone works fine with Centos or Ubuntu, but not very well with windows. But I think they will improve it yet.

Thanks for the suggestions. I read into File Stream but people said it was causing API bans.

Here is what makes no sense with my Rclone mount:

Mount in Windows - laggy/crashy - everything takes forever to load into VLC or Plex.

Mount in Ubuntu with Virtualbox and share the folder with Samba can browse and play files with VLC almost instantly. Will have to map the drive to see how Plex works.

I’m having the same exact experience. I also tried without any commandline parameters, but also that doesn’t improve on things.

I’m happy to provide any debug info @ncw needs if he has time too look into this.

Tests I can repeat are most useful… I’d really like to know the difference between Windows and Linux.

You could try this seek performance program I wrote

go run cmd/mount/test/seek_speed.go Q:\path\to\large\file\on\rclone\mount

(you’ll need the rclone source and go installed for that)

That will tell you how long seeks are taking. If you could compare Windows vs Linux that would be perfect and would give some hard data go go on!

Ubuntu 18.04.1: That took 1m12.674725093s for 25 iterations, 2.906989003s per iteration
Windows 10: That took 2m49.051889s for 25 iterations, 6.76207556s per iteration

This is with the same 8.2 GB file on Google Drive (Gsuite)

I also notice that in Ubuntu desktop browsing over the drive is considerably faster than on Windows

I ran the test a few more times and on both OS’s I don’t get consistant results.
On Ubuntu I also had a run of 2m29s and 1m54s
and on Windows 1m46s and 1m38s

@ncw If I can get more data or logs let me know what and how and I will dig it up :slight_smile:

Thanks for doing those tests. So it looks like that seeks are quite slow for you both under Windows and linux.

Have you made your own client id?? If you haven’t then I recommend you do - that will speed things up.

Your seek test timings are consistent with the use of the default set. I just tried it now - I got 2m24 for the default credentials and 26s for a set of my own credentials.

I was thinking about the browsing experience - is explorer making thumbnails of images/video - that will be slowing browsing down a lot.

1 Like

So I created the client ID and secret and updated the config.

At both Windows and Ubuntu the seek_speed.go takes around 15 seconds!! :smiley:

Going to test now what that means for Plex

Soo, this is MUCH!! better.

Plex movies now start in just under 10 seconds and also the Plex scanning is much faster.

To automount the drive use nssm and make sure to use the --config parameter otherwise it won’t work.
Run the service under system so all apps can see the mount.

These are my mount settings on Windows:
rclone mount Gdrive: P: --dir-cache-time=160h --cache-chunk-size=10M --cache-info-age=168h --cache-workers=5 --cache-tmp-upload-path D:\RCloneTmpUpload --cache-tmp-wait-time 60m --buffer-size 0M --vfs-cache-mode writes --config C:\Users\UserName.config\rclone\rclone.conf

Any thoughts on that?

Excellent :smiley:

Those looks sensible to me! I note that a lot of users are having success without using cache so you could try that too.

any chance to see the content of your rclone.conf ? - im basically trying to do the same thing but a bit unsure what the best way to run the cache is.

I’d suggest making a new topic about your question. But in a nut shell you create a config for Google. Then you reference that remote when you create the cache remote. The docs have a good example.