Windows Local Remote and Crypt

Hi everyone,

I’m having a severely noobish issue with setting up a local remote to crypt.

I was originally using rclone for ACD, but am playing around with a couple new options. Getting everything up (and back down) from ACD worked great when I originally set it up.

Now, I’m trying to set up a “remote” to a local path, and then crypt that local remote. I can’t seem to set up the local correctly and I was hoping someone could let me know what I’m missing. There is an option for “local filesystem” when setting up a new remote, but the only setup option is “nounc.” Where do I put in the actual path to the folder?

The other issue I’m running into with Windows is that whatever I try adds an extra slash. So “M:\Something\Here” shows up as “M:\Something\Here”. If I do an “rclone ls local:” after setting it up, it shows as “Directory not found.”

tl;dr - Don’t know how to make a local remote work on Windows.

I’m sure that I’m missing something easy. Thanks for any help and feedback!

What i did in that case is the following, i don’t know if its correct but it worked for me

For example, you want a local (non crypted) (m:\something\here) folder called remote, in the config you will have

type = local
nounc = true

and if you want to list that folder i run
rclone ls remote:m:\something\here
But, if i want to have a local crypted (m:\something\here\crypted) folder called remotecrypt i edited my config in this way

type = local
nounc = true

type = crypt
remote = remote:m:/something/here/crypted
filename_encryption = standard
password = …
password2 = …

And if you do
rclone ls remotecrypt:
it shows the unencrypted content of m:\something\here\crypted

Sorry about my english, not my native language. Hope this helps you

1 Like