Why is rclone sending data when copying from remote to local?

What is the problem you are having with rclone?

Trying to understand why rclone is transmitting continuous 500kb/s when copying content from google drive to local.

What is your rclone version (output from rclone version)

Yes, latest
rclone v1.56.0

  • os/version: raspbian 10.10 (64 bit)
  • os/kernel: 5.10.17-v8+ (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.16.5
  • go/linking: static
  • go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

  • os/version: raspbian 10.10 (64 bit)

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy ut-drive:Pictures /mnt/sgt/ut-drive/Pictures

The rclone config contents with secrets removed.

    "ut-drive": {
        "client_id": "",
        "client_secret": "",
        "scope": "drive",
        "team_drive": "",
        "token": "{\"access_token\":\"",\"token_type\":\"Bearer\",\"refresh_token\":\"\",\"expiry\":\"2021-07-30T15:32:01.260705773-04:00\"}",
        "type": "drive"

A log from the command with the -vv flag

This is consistently being used. I'm copying about 200GB from drive to local, for the first time with rclone.

rclone has to make a number of api calls to gdrive.

  1. list of files in a folder, there is a limit to the number of files per api call, so multiple api calls are needed.
    for gdrive, the max number of files listed per api call is 1000, which is what rclone uses by default.

  2. for a given file to download, rclone downloads the file as a number of chunks.
    for each chunk, rclone has to make an api call to gdrive to request the chunk.
    that can be tweak using --drive-chunk-size

  3. you can get a better understanding of what rclone is doing., using a debug output, by adding -vv to your command,

  4. if you want to see exactly what rclone is uploading, you can add this to your command
    --dump=bodies --retries=1 --low-level-retries=1 --log-level=DEBUG --log-file=rclone.log
    and read rclone.log

That flag is only for uploads and has nothing to do with downloads:


You gotta post a debug log as a screenshot of a network stat doesn't help answer your question.

thanks for the clarification, and i did read the documentation before posting.
i assume that since you did not comment on it, that the rest of what i wrote was correct.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.