Why does nothing copy?

What is the problem you are having with rclone?

rclone --progress copy /mnt/Backup My_Remote: results in nothing at all being copied

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

os/arch: freebsd/amd64 (on FreeNAS 11.3-RELEASE)
go version: go1.13.5

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /mnt/Backup MyRemote:
"MyRemote" is a psuedonym

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

How do I put the log into a file? I tried adding >>log and >log to the command but had no luck?


you need to a log file with debug level details.

  1. https://rclone.org/docs/#log-file-file

  2. https://rclone.org/docs/#logging

  3. you can add this flag when testing

  4. please update rclone to the lastest stable version v1.51.0

rclone --progress copy /mnt/Backup My_Remote: --log-file=/path/to/logfile.log -vv --dry-run

It would help if you can also specify more exactly what happens.

For example, does just nothing happen? (with --progress you should be seeing stats of the transfer)
Or does it stall at basically 0 speed?
Or does it appear to copy normally but you are not able to see the files on the remote?
Knowing how it fails would tell us a lot about what may be the probably cause.

And do you get any errors? Important errors should be visible even without -v (verbose), much -vv (debug output). If you are not getting any errors though then it is very useful to have a -vv log to look at.

Thanks for all the quick help. You suggest several steps, and because I'm going out of town tomorrow, today will have just snippets of time for me to do what you suggest. Nonetheless, since others may wish to follow in our footsteps, if any steps encounter glitches, I'll document them as I follow them.

asdffdsa's Step 4: Install v1.51.0.
I'm running rclone in an iocage jail on FreeNAS. First I installed the package management tool, pkg. Then I installed rclone. This was v1.50.2 as in my original post. Then, following the link in asdffdsa's post, I saw the instruction for installing v1.51.0 on FreeBSD (FreeNAS rides on top of FreeBSD).

Since FreeNAS is a server system intended for headless use, it does not come with a browser. So I used the command line argument prescribed on the page:
curl https://rclone.org/install.sh | sudo bash

This caused some misleading error messages and makes one bad assumption. Since I'm running this in a jail, I can work as root. Hence, no need for the "sudo," which throws an unrecognized command error anyway. More seriously, the system did not have curl installed, so I used pkg to install it.

There was still a problem in that the first part of the pipe now worked, and displayed a shell script, but piping it into bash created an error. Some web searching revealed this was due to the receiving program not staying open long enough to receive information from the preceding one. So initially I tried a suggested solution of inserting fast intermediate steps, "cat" in my case. It still didn't work.

So I tried to see if bash would run by itself and discovered it wasn't installed. I thought of using the jail's default shell, csh, instead but realized the script probably uses bash-specific commands. So I used pkg to install bash.

This worked. Thankfully, I'm knowledgeable about *nix and could problem-solve this by myself. Hopefully, this post will provide guidance so others don't have to.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.