When using Crypt do --bwlimit and -v affect crypt, or the underlying remote?

I am using crypt with a b2 remote, and I’m wondering if the -v and --bwlimit options are supposed to apply to the encryption process, or the upload of encrypted files to b2, or both?

For example, if I don’t set a --bwlimit and use the -v flag, I see that large files show a “transfer speed” that’s many times fast than my upload bandwidth (my max upload bandwidth is ~1MiB/s and I see “transfer” speeds of at least 10x this).

Once large files reach 100%, they then sit around with a transfer speed of 0 Bytes /s and an ETA of 0s, and they stay in that state for a long time (tens of minutes).

What I presume is happening is that the -v flag shows me the process of the large files being encrypted (into memory, I presume?) - i.e. it shows me the literal process of crypt – and then once encryption is finished (100%) the files sit around in memory and I see “ETA: 0s” while they upload to b2.

Similarly, if I try setting a --bw-limit, it looks like that limit is also applied to the encryption process, rather than the upload of files to bw.

So I guess I have two questions - i) am I correct about what’s going on? and ii) is there a way to see the upload progress and apply bandwidth limits to the underlying remote when using crypt?


-v applied to the whole of rclone

–bwlimit only applies to network transfers

Which version of rclone are you using? I’ve fixed this in https://github.com/ncw/rclone/issues/602

Unless you have a really slow computer, encrypting the 96MiB chunks rclone uses should take less than a second.

Do you see the same without crypt?

Thanks for the response!

This is with 1.36

I have since switched to a crypt / acd backend, and the problem has disappeared

I still get that with v1.36-20 actually:

It is not a permanent state though, i’d guess that the “0 kb/s 100%” state lasts at most a couple of minutes.

With b2?

I wonder what is happening at that moment.

Glad to hear it is transient though!