What does the <6> before INFO mean and will it always be 6?

What is the problem you are having with rclone?

No problem. Just looking for information.

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.2
- os/version: debian 12.2 (64 bit)
- os/kernel: 6.1.0-13-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.3
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Photos.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy -v /data/to/sync gp:album/ZZZ

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[b2]
type = b2
account = XXX
key = XXX
hard_delete = true

[gp]
type = google photos
token = XXX
client_id = XXX
client_secret = XXX
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

This is my output with -v not -vv:

transferring files from source '/source' to destination 'gp:destination'
<6>INFO  : folder1/folder2/folder3/IMG_9008.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9009.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9011.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9012.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9010.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9014.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9013.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9016.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9015.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9018.jpg: Copied (new)
<6>INFO  : folder1/folder2/folder3/IMG_9019.jpg: Copied (new)

What does the <6> mean and will it always be 6?

Documentation says it will prefix "all log messages with their level in capitals, e.g. INFO" but it doesn't mention the 6?

Would be super helpful to know what version, command you are running, etc. Basically, the stuff you deleted from the help and support template.

Sorry. I'm not having a problem so I didn't think that information was relevant/necessary. I edited the question with all of the template information.

There is nothing wrong. Everything is working as expected. I just can't find any information in the documentation about what the <6> is.

The command you used does not make any 6s or whatnot in the logs.

texter@macmini Downloads % rclone copy /etc/hosts GD: -vv
2023/11/27 10:17:05 DEBUG : rclone: Version "v1.65.0" starting with parameters ["rclone" "copy" "/etc/hosts" "GD:" "-vv"]
2023/11/27 10:17:05 DEBUG : Creating backend with remote "/etc/hosts"
2023/11/27 10:17:05 DEBUG : Using config file from "/Users/texter/.config/rclone/rclone.conf"
2023/11/27 10:17:05 DEBUG : fs cache: adding new entry for parent of "/etc/hosts", "/etc"
2023/11/27 10:17:05 DEBUG : Creating backend with remote "GD:"
2023/11/27 10:17:05 DEBUG : Google drive root '': 'root_folder_id = 0AGoj85v3xeadUk9PVA' - save this in the config to speed up startup
2023/11/27 10:17:05 DEBUG : hosts: Sizes differ (src 213 vs dst 445)
2023/11/27 10:17:06 DEBUG : hosts: md5 = a3f51a033f988bc3c16d343ac53bb25f OK
2023/11/27 10:17:06 INFO  : hosts: Copied (replaced existing)
2023/11/27 10:17:06 INFO  :
Transferred:   	        213 B / 213 B, 100%, 212 B/s, ETA 0s
Transferred:            1 / 1, 100%
Elapsed time:         1.3s

2023/11/27 10:17:06 DEBUG : 8 go routines active

I'm not sure what to say. I just did a sync between two local folders and see the same thing.

$ rclone -v sync tmp1/ tmp2/
<6>INFO  : 001.jpg: Copied (new)
<6>INFO  : 002.jpg: Copied (new)
<6>INFO  : 003.jpg: Copied (new)
<6>INFO  : 004.png: Copied (new)
<6>INFO  : 005.bmp: Copied (new)
<6>INFO  : 
Transferred:      143.288 MiB / 143.288 MiB, 100%, 0 B/s, ETA -
Transferred:            5 / 5, 100%
Elapsed time:         0.2s

Or with -vv:

$ rclone -vv sync tmp1/ tmp3/
<7>DEBUG : rclone: Version "v1.64.2" starting with parameters ["rclone" "-vv" "sync" "tmp1/" "tmp3/"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Creating backend with remote "tmp1/"
<7>DEBUG : Using config file from "/home/nacho/.config/rclone/rclone.conf"
<7>DEBUG : fs cache: renaming cache item "tmp1/" to be canonical "/home/nacho/Pictures/private/people/tmp1"
<7>DEBUG : Creating backend with remote "tmp3/"
<7>DEBUG : fs cache: renaming cache item "tmp3/" to be canonical "/home/nacho/Pictures/private/people/tmp3"
<7>DEBUG : 001.jpg: Need to transfer - File not found at Destination
<7>DEBUG : 002.jpg: Need to transfer - File not found at Destination
<7>DEBUG : 003.jpg: Need to transfer - File not found at Destination
<7>DEBUG : 004.png: Need to transfer - File not found at Destination
<7>DEBUG : 005.bmp: Need to transfer - File not found at Destination
<7>DEBUG : Local file system at /home/nacho/Pictures/private/people/tmp3: Waiting for checks to finish
<7>DEBUG : Local file system at /home/nacho/Pictures/private/people/tmp3: Waiting for transfers to finish
<7>DEBUG : 001.jpg: md5 = 28cdc72ef6466e162cd77da8665e78be OK
<7>DEBUG : 001.jpg.vibenav8.partial: renamed to: 001.jpg
<6>INFO  : 001.jpg: Copied (new)
<7>DEBUG : 002.jpg: md5 = 31743dbac2162721c94933f5821c1b82 OK
<7>DEBUG : 002.jpg.dazixoz9.partial: renamed to: 002.jpg
<6>INFO  : 002.jpg: Copied (new)
<7>DEBUG : 003.jpg: md5 = 991c17de61f76d9e2e8e679b02ba9dbb OK
<7>DEBUG : 003.jpg.vuxeyor7.partial: renamed to: 003.jpg
<6>INFO  : 003.jpg: Copied (new)
<7>DEBUG : 004.png: md5 = 10dfeb8efb6113b9052908dbed3bbba5 OK
<7>DEBUG : 004.png.gofufid7.partial: renamed to: 004.png
<6>INFO  : 004.png: Copied (new)
<7>DEBUG : 005.bmp: md5 = 45d9e8f89b43819c77ec124b4aff1e20 OK
<7>DEBUG : 005.bmp.vikisel8.partial: renamed to: 005.bmp
<6>INFO  : 005.bmp: Copied (new)
<7>DEBUG : Waiting for deletions to finish
<6>INFO  : 
Transferred:      143.288 MiB / 143.288 MiB, 100%, 0 B/s, ETA -
Transferred:            5 / 5, 100%
Elapsed time:         0.3s

<7>DEBUG : 6 go routines active

^^^^^^

That's syslog support you have turned on.

And <6> or <7> are syslog severity levels - at least for Linux I know they are as follows:

           0       Emergency: system is unusable
           1       Alert: action must be taken immediately
           2       Critical: critical conditions
           3       Error: error conditions
           4       Warning: warning conditions
           5       Notice: normal but significant condition
           6       Informational: informational messages
           7       Debug: debug-level messages

but I am not sure it will be always the same - check your OS documentation.

I have not done anything to enable syslog support. I did a fresh install straight from rclone website.

So I'm not sure....

Ah. So it's part of the INFO prefix. Got it. It wasn't mentioned in the documentation so I wasn't sure. Thank you!

Can you share the new output of

rclone version
rclone config redacted
env

No it is not part of the INFO prefix as it's part of the systemd format.

This means you have a systemd environment variable set. I think it is INVOCATION_ID

What do you get if you

echo $INVOCATION_ID

I think something should have cleaned that from your environment.

If you unset INVOCATION_ID then run rclone does it run as normal?

Okay? I haven't done/changed anything.

$ rclone version
rclone v1.64.2
- os/version: debian 12.2 (64 bit)
- os/kernel: 6.1.0-13-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.3
- go/linking: static
- go/tags: none

$ rclone config redacted
[b2]
type = b2
account = XXX
key = XXX
hard_delete = true

[gp]
type = google photos
token = XXX
client_id = XXX
client_secret = XXX
### Double check the config for sensitive info before posting publicly

$ env
SHELL=/bin/bash
SESSION_MANAGER=local/desk:@/tmp/.ICE-unix/2038,unix/desk:/tmp/.ICE-unix/2038
WINDOWID=2
QT_ACCESSIBILITY=1
COLORTERM=truecolor
XDG_CONFIG_DIRS=/home/myusername/.config/kdedefaults:/etc/xdg:/usr/share/desktop-base/kf5-settings
SSH_AGENT_LAUNCHER=openssh
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session1
LANGUAGE=
SSH_AUTH_SOCK=/run/user/1000/openssh_agent
SHELL_SESSION_ID=e04c5dadc91843309f80949cb3c2aca1
DESKTOP_SESSION=plasmawayland
GTK_RC_FILES=/etc/gtk/gtkrc:/home/myusername/.gtkrc:/home/myusername/.config/gtkrc
XCURSOR_SIZE=48
GTK_MODULES=gail:atk-bridge
XDG_SEAT=seat0
PWD=/home/myusername
XDG_SESSION_DESKTOP=KDE
LOGNAME=myusername
XDG_SESSION_TYPE=wayland
SYSTEMD_EXEC_PID=2074
XAUTHORITY=/run/user/1000/xauth_pCaHXy
XKB_DEFAULT_MODEL=pc105
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/myusername/.gtkrc-2.0:/home/myusername/.config/gtkrc-2.0
HOME=/home/myusername
LANG=en_US.UTF-8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=00:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.avif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.webp=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:*~=00;90:*#=00;90:*.bak=00;90:*.old=00;90:*.orig=00;90:*.part=00;90:*.rej=00;90:*.swp=00;90:*.tmp=00;90:*.dpkg-dist=00;90:*.dpkg-old=00;90:*.ucf-dist=00;90:*.ucf-new=00;90:*.ucf-old=00;90:*.rpmnew=00;90:*.rpmorig=00;90:*.rpmsave=00;90:
XDG_CURRENT_DESKTOP=KDE
KONSOLE_DBUS_SERVICE=:1.91
WAYLAND_DISPLAY=wayland-0
KONSOLE_DBUS_SESSION=/Sessions/1
PROFILEHOME=
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
QTWEBENGINE_DICTIONARIES_PATH=/usr/share/hunspell-bdic/
INVOCATION_ID=bfe0db445da84077bf61b0b781269e66
KONSOLE_VERSION=221203
MANAGERPID=1849
KDE_SESSION_UID=1000
XKB_DEFAULT_LAYOUT=us
XDG_ACTIVATION_TOKEN=kwin-5
XDG_SESSION_CLASS=user
TERM=xterm-256color
USER=myusername
COLORFGBG=15;0
PLASMA_USE_QT_SCALING=1
KDE_SESSION_VERSION=5
PAM_KWALLET5_LOGIN=/run/user/1000/kwallet5.socket
QT_WAYLAND_FORCE_DPI=96
DISPLAY=:1
SHLVL=1
XDG_VTNR=1
XDG_SESSION_ID=3
XDG_RUNTIME_DIR=/run/user/1000
QT_AUTO_SCREEN_SCALE_FACTOR=0
JOURNAL_STREAM=8:24450
XCURSOR_THEME=breeze_cursors
KDE_FULL_SESSION=true
PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
KDE_APPLICATIONS_AS_SCOPE=1
KONSOLE_DBUS_WINDOW=/Windows/1
_=/usr/bin/env

Got it.

$ echo $INVOCATION_ID
bfe0db445da84077bf61b0b781269e66

I never set it so I'm not sure? All I did was install using instructions from https://rclone.org/install/:

sudo -v ; curl https://rclone.org/install.sh | sudo bash

I think I've done a selfupdate since then.

Yes. But I'm wondering where/how INVOCATION_ID got set since I never set it.

I think it's a new default on Debian perhaps as I never recall it being set either.

I think in some systems the desktop or ssh environment gets started from systemd and the INVOCATION_ID gets inherited.

Are you using ssh to log in or are you using a desktop? GIve us more info about how you are logged in :slight_smile:

I think this is a bug in debian - it should clean the INVOCATION_ID from the environment before it gets to running the desktop.

I have just tried one of my Debian 12 machines:

$ rclone ls . -vv
<7>DEBUG : rclone: Version "v1.65.0" starting with parameters ["rclone" "ls" "." "-vv"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Creating backend with remote "."
<7>DEBUG : Using config file from "/home/db/.config/rclone/rclone.conf"
<7>DEBUG : fs cache: renaming cache item "." to be canonical "/home/db/Downloads"
<7>DEBUG : 4 go routines active

no ssh, desktop KDE environment

Its either a bug in Debian or we need a better way of detecting we are running under systemd!

I am on Debian 12 + KDE. I use it as my daily driver so I am physically connected to my machine. My wife says I'm too connected to it, too long, but that's another story.

1 Like

If someone can tell me what to do or check for, I am happy to set up a few VMs and test for y'all.

Using this may be better: StderrIsJournalStream

Returns true if JOURNAL_STREAM environment variable is present, and stderr's device and inode numbers match it.

Tt looks a much better than the test we have at the moment.

Do you have JOURNAL_STREAM in your environment @imthenachoman

@darthShadow do you want to make a PR for this?

PR: systemd: Fix detection and switch to the coreos package everywhere by darthShadow · Pull Request #7467 · rclone/rclone · GitHub

Builds for testing are available here: v1.66.0-beta.7554.3d7c40078.fix-systemd-detection

1 Like