WebDAV/Nextcloud problems with chunked upload and connection reset by peer

What is the problem you are having with rclone?

I most likely have a problem with my nextcloud service and not rclone, I just hope to solve it with rclone. :slight_smile:

The service I'm using is really flaky and often (very often) respond with:

Failed to move with 3 errors: last error was: uploading chunk failed: Put "https://nextcloud.invalid/remote.php/dav/uploads/me%40example.invalid/rclone-chunked-upload-42a13ecbc050ef8305a6859f5170e8f9/000001073741824-000001342177279": write tcp 10.0.0.180:41800→aa.bb.cc.dd:443: write: connection reset by peer

I've tried playing around with …
… nextcloud_chunk_size: 0, default, 16M, 64M, 256M, 512M
… --expect-continue-timeout: default, 10s, 1m
… --timeout: default, 10m, 5s
… --transfers: 1, 2, 3, 4

I also tried the beta from webdav: nextcloud: rclone incorrectly retries long server-side chunks merge operations before they complete · Issue #7109 · rclone/rclone · GitHub. I tried uploading from different systems, so it's not on my end.

Is there any option I could try to get the chunked upload to retry more often or somehow resume the connection which just got dropped?

The files I'm trying to copy are quite large (>10G).

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 5.15.0-1048-oracle (aarch64)
- os/type: linux
- os/arch: arm64 (ARMv8 compatible)
- go/version: go1.21.4
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

WebDav, Nextcloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vP copy localfile remote:

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[remote]
type = webdav
url = https://XXX/remote.php/dav/files/XXX
user = XXX
pass = XXX
vendor = nextcloud
nextcloud_chunk_size = 256M
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

2023/11/30 17:24:03 ERROR : file: Failed to copy: uploading chunk failed: Put "https://XXX/remote.php/dav/uploads/XXX/rclone-chunked-upload-8bdb7e8de4f17d559de39c6bb9165a44/000000000000000-000000268435455": write tcp 10.0.0.180:47866→aa.bb.cc.dd:443: write: connection reset by peer

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.