--vfs-read-chunk-size-limit=-1 is that valid value?

What is the problem you are having with rclone?

Fatal error: invalid argument "-1" for "--vfs-read-chunk-size-limit" flag: size can't be negative "-1"

https://rclone.org/commands/rclone_mount/#chunked-reading
A value of -1 will disable the limit and the chunk size will grow indefinitely.

What is your rclone version (output from rclone version)

rclone v1.53.1

  • os/arch: windows/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

w10.2004.64

Which cloud storage system are you using? (eg Google Drive)

sftp

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount seedboxsftp: s: --read-only --no-checksum --no-modtime --rc --vfs-cache-mode=full --cache-dir=b:\rclone\cache --vfs-read-chunk-size-limit=-1 --log-level=DEBUG --log-file=C:\data\rclone\scripts\rr\mount\log.mount.sftp.txt

The rclone config contents with secrets removed.

[seedboxsftp]
type = sftp
host = appbox.local
user = ecCsXa9Y3zHQGheKOcwS
port = 9999
pass = *** ENCRYPTED ***
key_file_pass = *** ENCRYPTED ***
use_insecure_cipher = true
md5sum_command = md5sum
sha1sum_command = sha1sum
--------------------```

#### A log from the command with the `-vv` flag  
<!-- You should use 3 backticks to begin and end your paste to make it readable.  Or use a service such as https://pastebin.com or https://gist.github.com/   -->

no log as rclone complains about flag value

Try setting it to off instead. The docs probably need to be corrected.

thanks, no error but i have not yet tested is the flag gives the correct behavior

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.