Varying download speeds with ACD

Do any of you guys experience drastic varying speeds with ACD depending on the size of the file… Larger files, like movies that are greater than 10GBs, download on average between 10-15 MB/s which result in perfect streams. However , and this is puzzling, files that are smaller than that, including most tv shows average 0-1MB/s (or sometimes stall) which result in terrible streams that time out.

anyone getting a similar experience?


I’ve been having the exact same issue lately. It’s made ACD pretty unreliable for Plex. It only started happening maybe a month or two ago. I would be happier if all files transferred at a lowly but adequate 4MB/s as opposed to the 500kB/s vs 15MB/s roulette.

Edit: I’ve noticed that the affected “slow” files also initially download at a crawl even via the Amazon Drive web interface. However via Amazon’s interface these slow downloads will usually pick up steam and achieve full speeds after some time. Sometimes transfers via the ACD mount also pick up speed, but often they will just hang instead.


i mentioned this issue on other topic, but it seems people just ignored it. well sooner or later they start listening me.
i will explain short:
Running rclone in debug mode you will see the transfer chunks.
after examination it i saw some takes longer to respond and took timeouts on emby(i dont use plex)
this was fixed with timeout to 10seconds, i know its a CRUDE fix but well if you want seek speed this is only way to get it. you need also raise low retry limit to more than 3. after do this modification you will get them alot.

other thing the amazon has like hundreds of endpoint servers, you need to go one by one and take out the slow ones… i managed to take 5-10 fastest on my location and almost all issues at the time gone. after having this acd problems couple days ago i needed disable it, haven’t yet checked out if it still works.
This is main reason why you get varying speeds with ACD

it will get slower and slower as users grow on service, this is not getting any better if acd dont fix the problem between endpoint and the disk speeds, its all about it, they have slow seek because this is not business service.


This seems like an interesting solution. How would I go about doing this?

manipulate the dns, go the ip:s one by one first. spend time on it be patient and test. then finally do a list of good ip, and force the OS using those.
for start you can use /etc/hosts file to get one ip and test out. there is hundreds of servers, on my case all 52.x and 54.x ip:s are very slow on europe.
verify on the fly with netstat or something else that rclone is using that ip for transfer.

Last time i was doing some test I noticed that end points were not slow all the time, eg you may have bad luck and connect to end point that is really busy eg slow and couple of hours later it works fine.

true. best way is find the ip:s on time where is people watching tv. so you can find the slow servers. and yes you need more than one ip for redundancy.

So how do you manipulate which IP (endpoint) rclone is going to use when you have a bunch of known good ones?

is this still the best method to get around this issue? i’m having major issues with all files less than 7gbs… its odd that this would seemingly only affect files less than a certain size.