V1.56 (+beta) - I have to re-enter the password when editing the remote

Why do I have to re-enter the password when I edit the remote? It wasn't like this in the previous version!

version 1.55.1: OK

Edit remote
** See help for sftp backend at: https://rclone.org/sftp/ **

Value "host" = "****"
Edit? (y/n)>
y) Yes
n) No (default)
y/n>
Value "user" = "root"
Edit? (y/n)>
y) Yes
n) No (default)
y/n>
Value "port" = ""
Edit? (y/n)>
y) Yes
n) No (default)
y/n>
Value "pass" = "***"
Edit? (y/n)>
y) Yes
n) No (default)

Version 1.56 + beta: NOT OK

Edit remote
FTP host to connect to
Enter a string value. Press Enter for the default ("*****").
Choose a number from below, or type in your own value
 1 / Connect to ftp.example.com
   \ "ftp.example.com"
host>
FTP username, leave blank for current username, root
Enter a string value. Press Enter for the default ("*****").
user>
FTP port, leave blank to use default (21)
Enter a string value. Press Enter for the default ("").
port>
FTP password
y) Yes type in my own password
g) Generate random password
y/g>

Aaaaargggh!! :rage:

Thanks for reporting. Don't know how/why this changed, but I can look into it when I get back to my in progress PR #5551, since it is already messing around in (hopefully improving) the interactive config command source.

Ok great! Do you need anything from me?

Yes: Patience. :smirk:

I have reproduced it, so I have what I need at the moment, but thanks. :slight_smile:

Do you think you can meet the v1.57 release?.. No pressure: I am just asking!

Hopefully. I have proposed a solution that is up for review. :crossed_fingers:

By the way: The suggestion is not to bring back the dedicated edit process from previous versions, since it seemed that was deliberately removed to handle some other workflow:

Value "port" = "2222"
Edit? (y/n)>
y) Yes
n) No (default)

Instead I'm detecting that there is already a value set, and for (required) password options adding a third n) option:

FTP password
y) Yes, type in my own password
g) Generate random password
n) No, keep existing (default)

OK thank you, as long as I don't have to grab that password it's fine!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.