V1.35 Windows10, rclone hang when using samba share folder as source


I use a PC running linux as file server at home. Folders are shared via Samba to other Windows PC.

When I tried to copy files from one folder to onedrive using:
rclone check \Homeserver\Data\Sync Onedrive:\Sync

I got the check results, however, rclone would hang at
One drive root ‘Sync’: Waiting for checks to finish
Ctrl+C wouldn’t release it.

Maybe due to UNC path, but I don’t know where to find .rclone.conf file on windows and how to modify it.

Any help is appreciated.

PS. I tried to add a remote named “local” for local drive using
rclone config

I have
nounc = ture

Then I ran
rclone check local:z:\Sync Onedrive:\Sync

This time rclone does not translate the path into \?\unc\Homeserver\Data\Sync, but used z:\Sync, however, it still hangs…

Try with -v for a bit more logging - see if that gives a clue.

Also you want Onedrive:Sync - lose the backslash - rclone remote paths are always specified in unix style. I don’t know if that will make a difference though.

Thanks ncw for your reply!

It turns out only thing I need is a bit more patience. I let it hang for a few hours last night and it was done this morning. :slight_smile: Maybe due to the number of files in this folder.

Some would say impatience is a virtue: http://threevirtues.com/ :wink:


Thank you for saying so. Cheers!